random crash [@ FindNextNode] in spellchk.dll while composing WordPress 2.0.3 blog posts

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: ezs, Assigned: mscott)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060707 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060707 Firefox/2.0b1

I don't know if WordPress is the culprit - I don't think so :) I didn't have this with the Bon Echo builds.

I keep getting 'regular' crashes while composing blog posts; FF will hang, then crash in spellchk.dll; it does this when focus goes from the compose window and then back.

spellchk.dll is v. 1.8.20060.5183

Talkbacks as below - hopefully at least a few of those are for this problem.

Reproducible: Sometimes

Steps to Reproduce:
I'll work on more steps to reproduce - including more work on narrowing it down to a particular set of actions.


Actual Results:  
crash in spellchk.dll
TB21088720M, TB21052411H, TB21024048X, TB21023260Z, TB21023258K, TB20769305H, TB20769073W

Expected Results:  
Not crash.

I'll dig more into this. I'll probably update to the latest as well: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060707 Firefox/2.0b1
(Reporter)

Comment 1

12 years ago
This isn't just using WordPress.

It seems that any text box with spellcheck enabled will sometimes drop a crash with spellchk.dll

I tested this with bugzilla.novell.com - repeatedly going in and out - and I got a crash.
Could you perhaps try again with latest branch build?
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8
Assignee: nobody → mscott
Severity: normal → critical
Component: General → Spelling checker
Product: Firefox → Core
QA Contact: general → spelling-checker
Version: unspecified → 1.8 Branch
> I'll work on more steps to reproduce - including more work on narrowing it down
> to a particular set of actions.

If you can reproduce with the latest branch build and could give precise steps to reproduce (with a accomanying testcase or url), that would be much appreciated.

From talkback ID: TB21052411H
FindNextNode  [c:/ builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/ extensions/spellcheck/src/mozInlineSpellWordUtil.cpp, line 147]
mozInlineSpellWordUtil::BuildSoftText  [c:/ builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/ extensions/spellcheck/src/mozInlineSpellWordUtil.cpp, line 611]
mozInlineSpellWordUtil::EnsureWords  [c:/ builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/ extensions/spellcheck/src/mozInlineSpellWordUtil.cpp, line 263]
mozInlineSpellChecker::HandleNavigationEvent  [c:/ builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/ extensions/spellcheck/src/mozInlineSpellChecker.cpp, line 1140]
mozInlineSpellChecker::KeyPress  [c:/ builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/ extensions/spellcheck/src/mozInlineSpellChecker.cpp, line 1242]
DispatchToInterface  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/content/events/src/nsEventListenerManager.cpp, line 144]
nsEventListenerManager::HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/content/events/src/nsEventListenerManager.cpp, line 1752]
nsDocument::HandleDOMEvent  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/content/base/src/nsDocument.cpp, line 4022]
nsGenericElement::HandleDOMEvent  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/content/base/src/nsGenericElement.cpp, line 2256]
PresShell::HandleEventInternal  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 6379]
PresShell::HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp, line 6215]
nsViewManager::HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/view/src/nsViewManager.cpp, line 2514]
nsViewManager::DispatchEvent  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/view/src/nsViewManager.cpp, line 2246]
HandleEvent  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/view/src/nsView.cpp, line 174]
nsWindow::DispatchEvent  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 1349]
nsWindow::DispatchKeyEvent  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 3598]
nsWindow::OnKeyDown  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 3745]
nsWindow::ProcessMessage  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 4719]
nsWindow::WindowProc  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp, line 1538]
USER32.dll + 0x8734 (0x77d48734)
USER32.dll + 0x8816 (0x77d48816)
USER32.dll + 0x89cd (0x77d489cd)
USER32.dll + 0x8a10 (0x77d48a10)
nsAppShell::Run  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/widget/src/windows/nsAppShell.cpp, line 159]
nsAppStartup::Run  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
main  [c:/builds/tinderbox/Fx-Mozilla1.8-release/WINNT_5.2_Depend/mozilla/browser/app/nsBrowserApp.cpp, line 61]
kernel32.dll + 0x16d4f (0x7c816d4f)
Summary: random crash in spellchk.dll while composing WordPress 2.0.3 blog posts → random crash [@ FindNextNode] in spellchk.dll while composing WordPress 2.0.3 blog posts
Reporter, any update on this?
You still see this crash happening with the latest 1.8.1 branch build?
(Reporter)

Comment 5

12 years ago
Latest builds seem a lot happier - I've not had this spellchk.dll crash since updating.

(Fighting a problem with the latest builds hitting 99% CPU instead - that's another defect)

I think this one can be closed out.

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.