Access Connections 4.1.x does not correctly set Proxy configuration

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
13 years ago
10 years ago

People

(Reporter: julssark, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

The proxy configuration (specifically the "automatic proxy configuration URL" ) in Firefox does not get set correctly when using IBM/Lenovo Access Connections v4.1.x software. Access Connections is used on laptops to change configurations based on the network being connected to.

Reproducible: Always

Steps to Reproduce:
1. Verify that Firefox is set to Direct Connect to the Internet (Tools->Options->Connection Settings->Direct Connect) and quit Firefox
2. Create/select a profile in Access Connections v4.1.x that uses an automatic configuration script (from the profile->Additional Settings tab->check Override Proxy Configuration->click Settings button->check "Use Automatic Configuration Script"->type in address "http://foo.com/proxy.cfg"
3. Connect using that profile
4. Run Firefox and check the proxy configuration settings

Actual Results:  
Automatic Proxy Configuration URL radio button is selected but URL text field is left blank

Expected Results:  
Automatic Proxy Configuration URL radio button is selected and the URL text field is set to "http://foo.com/proxy.cfg"

Ever since Lenovo/IBM updated Access Connections to v4.1, I've run into this bug. Prior versions of Access Connections worked correctly. I've verified this problem on two different ThinkPads both running Windows XP SP2. The bug occurs in Firefox 1.5.x as well as 2.0 beta 2.

I suspect the problem is on the IBM/Lenovo end but the 4.1 release coincided with a 1.5.x maintenance release of Firefox.
(Reporter)

Comment 1

13 years ago
Access Connections correctly sets the proxy on Internet Explorer 7.0 beta 3. 

IBM/Lenovo tech support was able to duplicate the bug and this was their response via email: "I am not aware of plans to attempt to fix the proxy with Firefox. I will let the development team know of the interest in having that option become available again."
(Reporter)

Comment 2

12 years ago
Fixed by Access Connections v4.21 which was released a couple of weeks ago.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 3

10 years ago
Julius:

any info from them about what they were doing wrong, and how they fixed it?
(Reporter)

Comment 4

10 years ago
I don't know what the root cause was or what Lenovo did to fix it. I just know it works correctly with newer versions of Access Connections. 

Comment 5

10 years ago
RESOLVED-> WFM.

Julius:

I'm happy to hear that IBM/Lenovo fixed the problem. I'll talk to the SMO people to see if there is a place to store compatibility information like this.

One last question: was the problem that Access Connections did not set the PAC value, or that installing it made it impossible to set the value in the Firefox UI?

(In other words, was there a strange incompatibility that would break Firefox's ability to function normally? I'm asking because most other bug reports seem to have that problem, and nobody has figured out why it happened.)
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 6

10 years ago
Ben:

The problem was that Access Connections did not set the APC value. The Firefox interface functioned normally (i.e. after Access Connections failed to set the APC value, the user could set the APC value using Firefox).

julius

Comment 7

10 years ago
V/wfm. Thanks for the info.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.