Duplicate arcs in downloads.rdf are possible (e.g. double DownloadState/ProgressPercent)

RESOLVED FIXED in mozilla1.9alpha4

Status

()

RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: zeniko, Unassigned)

Tracking

Trunk
mozilla1.9alpha4
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
... which confuses e.g. SessionStore which restarts downloads where the first DownloadState arc equals DOWNLOAD_DOWNLOADING/0.

Maybe part of the same bug (otherwise please file an additional one): DownloadsRoot can contain several redundant references to the same RDF object.

See the URL for an example of a hosed up downloads.rdf.
(Reporter)

Comment 1

12 years ago
As for the steps to reproduce, you'll have to ask bzbarsky who claims that this happens whenever he actually uses the DM (see bug 345012 comment #10). :)
No longer possible on trunk due to Bug 380250.  Death to rdf
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Depends on: 380250
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 alpha4
Version: unspecified → Trunk
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.