Compile errors in gtkxtbin. Cant find X11/Intrinsic.h, X11/Shell.h and X11/StringDefs.h

RESOLVED WORKSFORME

Status

Firefox Build System
General
RESOLVED WORKSFORME
12 years ago
5 months ago

People

(Reporter: Martin, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Ubuntu/edgy Firefox/1.5.0.4
Build Identifier: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/bonecho-beta1-candidates/rc3/firefox-2.0b1.en-GB.linux-i686.tar.gz

Can't build firefox-2.0b1 on Ubuntu Edgy.
The output from make looks like:

In file included from gtk2xtbin.h:44,
                 from gtk2xtbin.c:46:
../../../dist/include/system_wrappers/X11/Intrinsic.h:3:32: error: X11/Intrinsic.h: No such file or directory
In file included from gtk2xtbin.c:46:
gtk2xtbin.h:78: error: expected specifier-qualifier-list before ‘Widget’

Similar error are reported for X11/Shell.h and X11/StringDefs.h


Reproducible: Always




gcc version 4.1.2 20060715 (prerelease) (Ubuntu 4.1.1-9ubuntu1)
(Reporter)

Comment 1

12 years ago
Update:
I installed libxt-dev and gov a different output from make.
A lot of errors like this:

gtk2xtbin.o: In function `xt_client_focus_listener':
gtk2xtbin.c:(.text+0x123a): undefined reference to `XtDisplay'
gtk2xtbin.c:(.text+0x1245): undefined reference to `XtWindow'
gtk2xtbin.c:(.text+0x1290): undefined reference to `XtWindowToWidget'
gtk2xtbin.c:(.text+0x12c5): undefined reference to `XtWindowToWidget'
collect2: ld returned 1 exit status

Comment 2

12 years ago
How did you get passed the configure stage if you didn't have libXt-dev installed?  There's an explicit check for <X11/Intrinsic.h> .  There's an explicit check for -lXt as well.

After installing libXt-dev, did you do a build from scratch (ie, 'make distclean', then rebuild) ?
Status: UNCONFIRMED → NEW
Component: Build Config → Build Config
Ever confirmed: true
Product: Firefox → Core
QA Contact: build.config → build-config
Version: unspecified → Trunk
(Reporter)

Comment 3

12 years ago
When I looked in the config.log, I could see there was an error about not finding X11/Intrinsic.h, but I can't remember that the configure aborted with error.

Made a distclean as suggested and now the build went through. Posting this with my FF2.0beta and it seems to be working so far. There are still a few errors in the config.log though. Some of them says something about not finding files:

configure:8040:27: error: sys/byteorder.h: No such file or directory
configure:9224:35: error: X11/extensions/XIElib.h: No such file or directory
configure:8040:20: error: compat.h: No such file or directory
configure:18866:27: error: sys/int_types.h: No such file or directory
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 4

2 years ago
I verified whether I had that record, and I did, then I wrote in rpm - q - f/usr/incorporate/X11/Intrinsic.h to perceive what bundle had set it there. 

Additionally, I a little while ago, I wrote: yum gives Intrinsic.h and that excessively recorded it as originating from libXt-devel. It's weird that it didn't work for you. It may have been on the grounds that I as of now had the bundle, which is still interesting since I thought it would seek all bundles.http://www.bestessaywritingservice.co/

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.