OpenType "liga" feature not working on Mac OS X ?

RESOLVED DUPLICATE of bug 345555

Status

--
major
RESOLVED DUPLICATE of bug 345555
12 years ago
12 years ago

People

(Reporter: webmestre, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Compare the Tifinagh composed on Mac OS X :

http://familleandries.iquebec.com/tifinar/essai-oiseau-de-feu.png

and what displayed when received and read in Thunderbid 1.5.0.4 under Windows XP SP 2...

<http://familleandries.iquebec.com/tifinar/tifinar-re%e7u-dans-oiseau-tonnerre-via-gmail.png>

Note how ligatures are not handled in the composition window on the Mac OS X but are properly display on Windows (and relatively well with Firefox under Windows incidentally : http://familleandries.iquebec.com/tifinar/re%e7u-tifinar-de-mac-oiseau-de-feu.png )


The corresponding HTML is here :

http://familleandries.iquebec.com/tifinar/essai-tifinar-avec-ligature.html

This seems really like a bad bug, I was surprized this failed, I looked briefly in the Bugzilla DB but I could not find this reported. (But I'n not really used to Bugzilla).


Font used : <http://familleandries.iquebec.com/tifinar/hapaxtifinarcarree.ttf>

Reproducible: Always

Steps to Reproduce:
1. Install font <http://familleandries.iquebec.com/tifinar/hapaxtifinarcarree.ttf>
2. Cut and Paste the content of <http://familleandries.iquebec.com/tifinar/essai-tifinar-avec-ligature.html>
3. Does it look like : <http://familleandries.iquebec.com/tifinar/tifinar-re%e7u-dans-oiseau-tonnerre-via-gmail.png> ? It should.

Actual Results:  
See : http://familleandries.iquebec.com/tifinar/essai-oiseau-de-feu.png

Expected Results:  
See : http://familleandries.iquebec.com/tifinar/tifinar-re%e7u-dans-oiseau-tonnerre-via-gmail.png
(Reporter)

Comment 1

12 years ago
See similar bug  for FireFox on Mac OS X (but not Windows).

https://bugzilla.mozilla.org/show_bug.cgi?id=345555

Comment 2

12 years ago
This is really the same bug as the one you reported on Firefox (It's a core bug that affects all products)

*** This bug has been marked as a duplicate of 345555 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.