Crash [@ nsEditor::NotifyEditorObservers] when observer->EditAction() is called

RESOLVED DUPLICATE of bug 278677

Status

()

Core
Editor
--
critical
RESOLVED DUPLICATE of bug 278677
12 years ago
12 years ago

People

(Reporter: Andreas Wuest, Unassigned)

Tracking

({crash})

1.8 Branch
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Firefox crashes with a "signal EXC_BAD_ACCESS, Could not access memory. Reason: KERN_INVALID_ADDRESS at address: 0x8d50000c" when calling observer->EditAction().

The nsIEditorObserver was installed using addEditorObserver via XPConnect.

Reproducible: Always

Steps to Reproduce:
1. Install nsIEditorObserver
2. Perform a user action in the editor

Actual Results:  
Crash.

Expected Results:  
Should call the EditAction() method of the installed nsIEditorObserver.

The gdb backtrace (could not get Talkback to log anything), produced with a debug build from tree 1.8.0, somewhere between Firefox 1.5.0.3 and 1.5.0.4:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x8d50000c
0x00878f84 in nsEditor::NotifyEditorObservers (this=0x1d450e00) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/base/nsEditor.cpp:1805
1805            observer->EditAction();
(gdb) bt
#0  0x00878f84 in nsEditor::NotifyEditorObservers (this=0x1d450e00) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/base/nsEditor.cpp:1805
#1  0x00875994 in nsEditor::EndPlaceHolderTransaction (this=0x1d450e00) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/base/nsEditor.cpp:970
#2  0x010bb1bc in nsAutoPlaceHolderBatch::~nsAutoPlaceHolderBatch (this=0xbfffb860, __in_chrg=2) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/base/nsEditorUtils.h:66
#3  0x010ba484 in nsAutoPlaceHolderBatch::~nsAutoPlaceHolderBatch (this=0xbfffb860) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/base/nsEditorUtils.h:66
#4  0x001e4468 in nsPlaintextEditor::InsertText (this=0x1d450e00, aStringToInsert=@0x1f5b2360) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/text/nsPlaintextEditor.cpp:776
#5  0x1b558834 in _XPTC_InvokeByIndex () at ../../../../../../dist/include/xpcom/xptcstubsdef.inc:256
#6  0x1b557fb4 in XPTC_InvokeByIndex (that=0x1d450ec8, methodIndex=9, paramCount=1, params=0xbfffbb10) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_ppc_rhapsody.cpp:144
#7  0x007b3ca0 in XPCWrappedNative::CallMethod (ccx=@0xbfffbdd0, mode=CALL_METHOD) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:2151
#8  0x0079cfbc in XPC_WN_CallMethod (cx=0x1f3c1a00, obj=0x1d339468, argc=1, argv=0x1d45dc90, vp=0xbfffbee0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp:1445
#9  0x1b260278 in js_Invoke (cx=0x1f3c1a00, argc=1, flags=0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/jsinterp.c:1188
#10 0x1b27358c in js_Interpret (cx=0x1f3c1a00, pc=0x1fd1a487 ":", result=0xbfffc7a0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/jsinterp.c:3583
#11 0x1b260304 in js_Invoke (cx=0x1f3c1a00, argc=1, flags=2) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/jsinterp.c:1208
#12 0x00c99938 in nsXPCWrappedJSClass::CallMethod (this=0x1cef7e30, wrapper=0x1fd98660, methodIndex=3, info=0x1d1783d0, nativeParams=0xbfffcbc0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp:1373
#13 0x00c940dc in nsXPCWrappedJS::CallMethod (this=0x1fd98660, methodIndex=3, info=0x1d1783d0, params=0xbfffcbc0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp:461
#14 0x1b55850c in PrepareAndDispatch (self=0x1fd98660, methodIndex=3, argsStack=0xbfffcd6c, argsGPR=0xbfffcccc, argsFPR=0xbfffcce8) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_ppc_rhapsody.cpp:184
#15 0x1b559074 in SharedStub () at ../../../../../../dist/include/xpcom/xptcstubsdef.inc:256
#16 0x0033e0cc in nsEventListenerManager::HandleEventSubType (this=0x1fd8b650, aListenerStruct=0x1fd98640, aDOMEvent=0x1fdce8d0, aCurrentTarget=0x1fdcee40, aSubType=8, aPhaseFlags=7) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/content/events/src/nsEventListenerManager.cpp:1687
#17 0x0033e620 in nsEventListenerManager::HandleEvent (this=0x1fd8b650, aPresContext=0x1f5bb790, aEvent=0xbfffd290, aDOMEvent=0xbfffd010, aCurrentTarget=0x1fdcee40, aFlags=7, aEventStatus=0xbfffd288) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/content/events/src/nsEventListenerManager.cpp:1786
#18 0x00391454 in nsXULElement::HandleDOMEvent (this=0x1fd8aa30, aPresContext=0x1f5bb790, aEvent=0xbfffd290, aDOMEvent=0xbfffd010, aFlags=7, aEventStatus=0xbfffd288) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/content/xul/content/src/nsXULElement.cpp:2138
#19 0x00394ba4 in nsXULElement::DoCommand (this=0x1fd8aa30) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/content/xul/content/src/nsXULElement.cpp:2738
#20 0x1b558834 in _XPTC_InvokeByIndex () at ../../../../../../dist/include/xpcom/xptcstubsdef.inc:256
#21 0x1b557fb4 in XPTC_InvokeByIndex (that=0x1fd8aa4c, methodIndex=111, paramCount=0, params=0xbfffd450) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_ppc_rhapsody.cpp:144
#22 0x007b3ca0 in XPCWrappedNative::CallMethod (ccx=@0xbfffd710, mode=CALL_METHOD) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:2151
#23 0x0079cfbc in XPC_WN_CallMethod (cx=0x1f3c1a00, obj=0x1d439da0, argc=0, argv=0x1d45dac0, vp=0xbfffd820) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp:1445
#24 0x1b260278 in js_Invoke (cx=0x1f3c1a00, argc=0, flags=0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/jsinterp.c:1188
#25 0x1b27358c in js_Interpret (cx=0x1f3c1a00, pc=0x1fd2631f ":", result=0xbfffe0e0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/jsinterp.c:3583
#26 0x1b260304 in js_Invoke (cx=0x1f3c1a00, argc=2, flags=2) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/jsinterp.c:1208
#27 0x1b26076c in js_InternalInvoke (cx=0x1f3c1a00, obj=0x1d338480, fval=490855960, flags=0, argc=2, argv=0x1fd9e3c0, rval=0xbfffe4b4) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/jsinterp.c:1285
#28 0x1b2170d4 in JS_CallFunctionValue (cx=0x1f3c1a00, obj=0x1d338480, fval=490855960, argc=2, argv=0x1fd9e3c0, rval=0xbfffe4b4) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/js/src/jsapi.c:4171
#29 0x003fdb50 in nsJSContext::CallEventHandler (this=0x1f52c7d0, aTarget=0x1d338480, aHandler=0x1d41de18, argc=2, argv=0x1fd9e3c0, rval=0xbfffe4b4) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/dom/src/base/nsJSEnvironment.cpp:1410
#30 0x003ef714 in nsGlobalWindow::RunTimeout (this=0x1f58ab60, aTimeout=0x1fd9e3d0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/dom/src/base/nsGlobalWindow.cpp:6382
#31 0x003f05ec in nsGlobalWindow::TimerCallback (aTimer=0x1fd9e420, aClosure=0x1fd9e3d0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/dom/src/base/nsGlobalWindow.cpp:6746
#32 0x1b530fd0 in nsTimerImpl::Fire (this=0x1fd9e420) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/xpcom/threads/nsTimerImpl.cpp:394
#33 0x1b53128c in handleTimerEvent (event=0x1fdb4450) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/xpcom/threads/nsTimerImpl.cpp:459
#34 0x1b5287b0 in PL_HandleEvent (self=0x1fdb4450) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/xpcom/threads/plevent.c:688
#35 0x1b5285c8 in PL_ProcessPendingEvents (self=0x1ca129d0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/xpcom/threads/plevent.c:623
#36 0x1b528d9c in _md_EventReceiverProc (info=0x1ca129d0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/xpcom/threads/plevent.c:1559
#37 0x907dc4cc in __CFRunLoopDoSources0 ()
#38 0x907db9fc in __CFRunLoopRun ()
#39 0x907db47c in CFRunLoopRunSpecific ()
#40 0x931e6740 in RunCurrentEventLoopInMode ()
#41 0x932cae5c in GetNextEventMatchingMask ()
#42 0x932cac10 in WNEInternal ()
#43 0x932cab70 in WaitNextEvent ()
#44 0x00b98334 in nsMacMessagePump::GetEvent (this=0x1ca334a0, theEvent=@0xbffff020) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/widget/src/mac/nsMacMessagePump.cpp:384
#45 0x00b98198 in nsMacMessagePump::DoMessagePump (this=0x1ca334a0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/widget/src/mac/nsMacMessagePump.cpp:281
#46 0x00553038 in nsAppShell::Run (this=0x1ca2cc00) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/widget/src/mac/nsAppShell.cpp:112
#47 0x006748d4 in nsAppStartup::Run (this=0x1ca2cbb0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/toolkit/components/startup/src/nsAppStartup.cpp:150
#48 0x0000cfcc in XRE_main (argc=1, argv=0xbffff654, aAppData=0x1378b80) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/toolkit/xre/nsAppRunner.cpp:2374
#49 0x00002c8c in main (argc=1, argv=0xbffff654) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/browser/app/nsBrowserApp.cpp:61
(gdb)

Comment 1

12 years ago
Does this crash on trunk or 1.8?
Severity: normal → critical
Keywords: crash
Version: Trunk → 1.8 Branch
(Reporter)

Comment 2

12 years ago
Created attachment 229982 [details]
Crashes the browser at observer->EditAction() in nsEditor::NotifyEditorObservers

As soon as you enter text in the editor frame, the browser crashes. In this testcase, the browser crashes with a "signal EXC_BAD_ACCESS, Could not access memory. Reason: KERN_PROTECTION_FAILURE at address: 0x0000000c" though, opposed to the reason reported in the original bug report. But the crash happens at the same place.
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Created an attachment (id=229982) [edit]
> Crashes the browser at observer->EditAction() in
> nsEditor::NotifyEditorObservers

The testcase needs to run in chrome.

As noted above, it yields a "KERN_PROTECTION_FAILURE at address: 0x0000000c" as opposed to "KERN_INVALID_ADDRESS at address: 0x8d50000c" in the original report. But anyway, it seems to be an access to a non-existent address in both cases.

The backtrace for the testcase is as follows:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x0000000c
0x00878f84 in nsEditor::NotifyEditorObservers (this=0x1d41e200) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/base/nsEditor.cpp:1805
1805            observer->EditAction();
(gdb) bt
#0  0x00878f84 in nsEditor::NotifyEditorObservers (this=0x1d41e200) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/base/nsEditor.cpp:1805
#1  0x00875994 in nsEditor::EndPlaceHolderTransaction (this=0x1d41e200) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/base/nsEditor.cpp:970
#2  0x010bb1bc in nsAutoPlaceHolderBatch::~nsAutoPlaceHolderBatch (this=0xbfffced0, __in_chrg=2) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/base/nsEditorUtils.h:66
#3  0x010ba484 in nsAutoPlaceHolderBatch::~nsAutoPlaceHolderBatch (this=0xbfffced0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/base/nsEditorUtils.h:66
#4  0x001c6e00 in nsHTMLEditor::TypedText (this=0x1d41e200, aString=@0xbfffcff0, aAction=2) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/html/nsHTMLEditor.cpp:1356
#5  0x001c6bf8 in nsHTMLEditor::HandleKeyPress (this=0x1d41e200, aKeyEvent=0x1f3d4e30) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/html/nsHTMLEditor.cpp:1317
#6  0x0088ed38 in nsTextEditorKeyListener::KeyPress (this=0x1ff9dc70, aKeyEvent=0x1f3d4e40) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/editor/libeditor/text/nsEditorEventListeners.cpp:242
#7  0x0033922c in DispatchToInterface (aEvent=0x1f3d4e40, aListener=0x1ff9dc70, aMethod=invalid pointer to member function
) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/content/events/src/nsEventListenerManager.cpp:141
#8  0x0033e588 in nsEventListenerManager::HandleEvent (this=0x1ff88210, aPresContext=0x1ff84b30, aEvent=0xbfffdbe0, aDOMEvent=0xbfffd430, aCurrentTarget=0x1d20eeb0, aFlags=514, aEventStatus=0xbfffd860) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/content/events/src/nsEventListenerManager.cpp:1779
#9  0x00316064 in nsDocument::HandleDOMEvent (this=0x1d20ee00, aPresContext=0x1ff84b30, aEvent=0xbfffdbe0, aDOMEvent=0xbfffd430, aFlags=514, aEventStatus=0xbfffd860) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/content/base/src/nsDocument.cpp:3944
#10 0x00409824 in nsGenericElement::HandleDOMEvent (this=0x1ff846f0, aPresContext=0x1ff84b30, aEvent=0xbfffdbe0, aDOMEvent=0xbfffd430, aFlags=519, aEventStatus=0xbfffd860) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/content/base/src/nsGenericElement.cpp:2208
#11 0x002598f0 in PresShell::HandleEventInternal (this=0x1d421e00, aEvent=0xbfffdbe0, aView=0x1ff85450, aFlags=1, aStatus=0xbfffd860) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/layout/base/nsPresShell.cpp:6430
#12 0x00258d74 in PresShell::HandleEvent (this=0x1d421e00, aView=0x1ff85450, aEvent=0xbfffdbe0, aEventStatus=0xbfffd860, aForceHandle=1, aHandled=@0xbfffd864) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/layout/base/nsPresShell.cpp:6214
#13 0x003a1304 in nsViewManager::HandleEvent (this=0x1ff853d0, aView=0x1ff85450, aEvent=0xbfffdbe0, aCaptured=0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/view/src/nsViewManager.cpp:2512
#14 0x003a0830 in nsViewManager::DispatchEvent (this=0x1ff853d0, aEvent=0xbfffdbe0, aStatus=0xbfffdab0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/view/src/nsViewManager.cpp:2246
#15 0x00923004 in HandleEvent (aEvent=0xbfffdbe0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/view/src/nsView.cpp:171
#16 0x00baafa0 in nsWindow::DispatchEvent (this=0x1ff854c0, event=0xbfffdbe0, aStatus=@0xbfffdb70) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/widget/src/mac/nsWindow.cpp:1809
#17 0x00bab098 in nsWindow::DispatchWindowEvent (this=0x1ff854c0, event=@0xbfffdbe0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/widget/src/mac/nsWindow.cpp:1824
#18 0x00ba3644 in nsMacEventHandler::HandleUKeyEvent (this=0x1ce36a50, text=0xbfffdd38, charCount=1, aOSEvent=@0xbfffdd10) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/widget/src/mac/nsMacEventHandler.cpp:1221
#19 0x00db7c14 in nsMacTSMMessagePump::UnicodeNotFromInputMethodHandler (theAppleEvent=0xbfffe1a0, reply=0xbfffe1b0, handlerRefcon=480457920) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/widget/src/mac/nsMacTSMMessagePump.cpp:531
#20 0x914f8960 in aeDispatchAppleEvent ()
#21 0x91503fc0 in sendToSelf ()
#22 0x914fc8f8 in AESendMessage ()
#23 0x914fc3d4 in aeSend ()
#24 0x9329438c in AESend ()
#25 0x932f9af0 in HandleTextInputEvent ()
#26 0x931ebde8 in ToolboxEventDispatcherHandler ()
#27 0x931e57a4 in DispatchEventToHandlers ()
#28 0x931e4cac in SendEventToEventTargetInternal ()
#29 0x931eba60 in SendEventToEventTarget ()
#30 0x932f98fc in SendTSMEvent ()
#31 0x932f904c in SendUnicodeTextAEToUnicodeDoc ()
#32 0x932f8a78 in utDeliverTSMEvent ()
#33 0x932f865c in TSMKeyEvent ()
#34 0x932af590 in TSMProcessRawKeyEvent ()
#35 0x932af058 in HandleCompatibilityKeyEvent ()
#36 0x931e22c0 in HIApplication::EventHandler ()
#37 0x931e5554 in DispatchEventToHandlers ()
#38 0x931e4cac in SendEventToEventTargetInternal ()
#39 0x931e4b28 in SendEventToEventTargetWithOptions ()
#40 0x932aed00 in HandleKeyboardEvent ()
#41 0x931ebddc in ToolboxEventDispatcherHandler ()
#42 0x931e57a4 in DispatchEventToHandlers ()
#43 0x931e4cac in SendEventToEventTargetInternal ()
#44 0x931eba60 in SendEventToEventTarget ()
#45 0x9322c7a0 in ToolboxEventDispatcher ()
#46 0x932cb3d8 in TryEventDispatcher ()
#47 0x932cb02c in GetOrPeekEvent ()
#48 0x932cae84 in GetNextEventMatchingMask ()
#49 0x932cac10 in WNEInternal ()
#50 0x932cab70 in WaitNextEvent ()
#51 0x00b98334 in nsMacMessagePump::GetEvent (this=0x1ca334a0, theEvent=@0xbffff020) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/widget/src/mac/nsMacMessagePump.cpp:384
#52 0x00b98198 in nsMacMessagePump::DoMessagePump (this=0x1ca334a0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/widget/src/mac/nsMacMessagePump.cpp:281
#53 0x00553038 in nsAppShell::Run (this=0x1ca2cc00) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/widget/src/mac/nsAppShell.cpp:112
#54 0x006748d4 in nsAppStartup::Run (this=0x1ca2cbb0) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/toolkit/components/startup/src/nsAppStartup.cpp:150
#55 0x0000cfcc in XRE_main (argc=1, argv=0xbffff654, aAppData=0x1378b80) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/toolkit/xre/nsAppRunner.cpp:2374
#56 0x00002c8c in main (argc=1, argv=0xbffff654) at /Users/awuest-devel/Documents/devel/src/mozilla/trees/MOZILLA_1_8_0_BRANCH/mozilla/browser/app/nsBrowserApp.cpp:61
(gdb) 
(Reporter)

Comment 4

12 years ago
(In reply to comment #1)
> Does this crash on trunk or 1.8?

I just ran the appended testcase on a Minefiled nightly from 20-Jul-2006 08:42, and it crashes as well (you have to hit return though to provoke a reaction from the editor, because with every other key, Find-As-You-Type intercepts the keypresses).
(Reporter)

Comment 5

12 years ago
(In reply to comment #1)
> Does this crash on trunk or 1.8?

With BonEcho (20-Jul-2006 07:59), things are a bit different: it does not crash, but it does not call EditAction() as well...

Should I report this as a separate bug?

Comment 6

12 years ago
Can you find a definite regression range for when it started crashing?
(Reporter)

Comment 7

12 years ago
(In reply to comment #6)
> Can you find a definite regression range for when it started crashing?

Unfortunately, I don't think so. I have used nsIEditorObserver today for the first time, so I don't have any track record on when it might still have worked and when not. Sorry!

Comment 8

12 years ago
Ria, can you help us figure out when we started crashing?
Not possible to enter text with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060720 BonEcho/2.0b1
(Reporter)

Comment 10

12 years ago
(In reply to comment #9)
> Not possible to enter text with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.8.1b1) Gecko/20060720 BonEcho/2.0b1

But you did run it from inside a chrome package, didn't you? The code needs extended privileges to run.
I clicked on the testcase link in order to run it in the browser window.
If it doesn't work that way please create an extension with the function.
As you are familiar with the problem it might work faster to find the regression range yourself. You can download all builds from beginning 2004 here: http://archive.mozilla.org/pub/firefox/nightly/ 
(Reporter)

Comment 12

12 years ago
(In reply to comment #11)
> I clicked on the testcase link in order to run it in the browser window.
> If it doesn't work that way please create an extension with the function.

Hmm, you mean I should attach an XPI?

> As you are familiar with the problem it might work faster to find the
> regression range yourself. You can download all builds from beginning 2004
> here: http://archive.mozilla.org/pub/firefox/nightly/
This is a duplicate of bug 278677, I can see the crash also in Mozilla1.7.12, so this is no (recent) regression.

*** This bug has been marked as a duplicate of 278677 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsEditor::NotifyEditorObservers]
You need to log in before you can comment on or make changes to this bug.