If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

visibility changes make HREF links unavailable

VERIFIED WORKSFORME

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: ian young, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Using document.getElementById(name).style.visibility to show/hide <div> elements
through JavaScript makes <a href...> tags unavailable. Mouse does not show them
as available links, though they are still underlined and in the link color for
the page.

Comment 1

18 years ago
The URL is not available. I'll create a testcase based on the comments and 
attach that. If the reporter can attach the original page as a testcase (or a 
subset that shows the problem) that would help too.

Comment 2

18 years ago
Created attachment 8362 [details]
Testcase: DIV is hidden and shown via visibility. Seems to work fine.

Comment 3

18 years ago
Though I cannot get to the testcase, I was able to create a testcase from the 
excellent description of the problem. This is working fine in a build from 
today. 

Marking WORKSFORME. Please reopen if the original URL still exhibits the problem 
- and if possible attach the page as a testcase.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
Adding 'verifyme' keyword
Keywords: verifyme

Comment 5

17 years ago
Works for me:
Platform: PC
OS: Windows 98
Mozilla Build: 2000101014 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.