the scrollbuttons and "All Tabs" button should not have tab context menus

RESOLVED WORKSFORME

Status

()

defect
--
minor
RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: ispiked, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

As of now, the scrollbuttons and the All Tabs button will give you a tab context menu (relating to the closest tab to it) when you right click on them.

Should these buttons really have a tab context menu?
Either there should be a context menu appropriate to the item itself (which is what I specced for the All Tabs button), or no context menu at all.  Showing a context menu for a nearby tab seems very wrong.
I think it should have it's own context-menu:

New tab     : Add new tab
First tab   : select  and seek first tab
Last tab    : select  and seek last tab
Current tab : make current tab visible in the tab strip

Also maybe:
open most recent closed tab
open all recent closed tabs  (not closing anything)

PS: I was thinking it shows context of selected tab which was wrong - one reason more for a separate context menu
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Summary: Should the scrollbuttons and "All Tabs" button have tab context menus? → the scrollbuttons and "All Tabs" button should not have tab context menus
Duplicate of this bug: 487828
You need to log in before you can comment on or make changes to this bug.