Closed Bug 345386 Opened 13 years ago Closed 11 years ago

Non-custom install progress meter refers to installing optional components when there aren't any

Categories

(Thunderbird :: Installer, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: u88484, Assigned: philor)

References

Details

(Keywords: polish)

Attachments

(1 file, 1 obsolete file)

With the new NSIS installer, when doing a non-custom install, the progress meter refers to installation optional components. Problem is there are no longer any more optional components. And if there were, they wouldn't have been optional in a non-custom install.

Possible Fix: Change wording to just Installing components
Severity: normal → trivial
Flags: blocking-thunderbird2?
Upon inspection of the code:
http://lxr.mozilla.org/mozilla/source/mail/locales/en-US/installer/custom.properties#68

I'm guessing in the config for the installer for non-custom install that someone has it set to install optional components but there aren't any...even in a custom install so I guess this line needs removed along with http://lxr.mozilla.org/mozilla/source/mail/installer/windows/nsis/installer.nsi#715 but then again talkback is listed there are part of the optional components but is configuarble if someone wants it installed or not.

So I guess it's back to changing the wording to Installing Components...?

Attached patch Proposed patch (obsolete) — Splinter Review
Attachment #230037 - Flags: review?
Attachment #230037 - Flags: review? → review?(mscott)
we didn't get this in before the l10n string freeze.
Flags: blocking-thunderbird2? → blocking-thunderbird2-
mscott review+?
They are optional components that are part of the Standard install. AFAIC this is WONTFIX.
Wasn't the point that there aren't actually any such optional components to choose (any more)? 
Assignee: mscott → nobody
Comment on attachment 230037 [details] [diff] [review]
Proposed patch

The localization key have to change when changing the text.
Attachment #230037 - Flags: review?(mscott) → review-
Since there are no optional components anymore then just use STATUS_CLEANUP or one of the other stages if it is during another stage
I know you've got plenty on your plate, but we're a touch short on Windows installer expertise, and it should be an easy review, since it's 90% copying bug 450164.
Assignee: nobody → philringnalda
Attachment #230037 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #343792 - Flags: review?(robert.bugzilla)
Severity: trivial → minor
OS: All → Windows XP
Hardware: All → PC
Version: unspecified → Trunk
Blocks: 453841
Comment on attachment 343792 [details] [diff] [review]
Remove the non-existent optional components

Looks good. It might be a good thing to reword OPTION_CUSTOM_DESC at some point but that should be in a separate bug. Thanks!
http://hg.mozilla.org/comm-central/rev/35e3e61336a8

I did try to think about OPTION_CUSTOM_DESC, but then I realized I could just wait for the Firefox wordsmiths to get to it, since it still has the same language :)
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b1
(In reply to comment #11)
> http://hg.mozilla.org/comm-central/rev/35e3e61336a8
> 
> I did try to think about OPTION_CUSTOM_DESC, but then I realized I could just
> wait for the Firefox wordsmiths to get to it, since it still has the same
> language :)
The majority of the strings came from me and then I ran them by UX which just approved the vast majority... so, if you or someone else can come up with a new string for Thunderbird we'd probably just go with that or with a minor modifcation to the string that is created.
What about Lightning in future? In german support forums I was asked to provide Lightning / the calendar only as an optional feature.
If calendar integration winds up being done in a way that works with optional install in the (Windows only) installer, rather than being optional in some other way, and if someone decides to make it optional in the installer, but they don't have any idea how to do it, then the patch here ought to get them started. I don't buy that as a reason to leave in installer code that looks specifically for DOMi and only shows the wizard page if DOMi is present, though. Nor do I buy leaving in unused strings speculatively, just in case someone might want to reuse them someday: that's just begging for trouble.
Duplicate of this bug: 450972
You need to log in before you can comment on or make changes to this bug.