Firefox crashes when waiting for the download manager to open [@ DocumentViewerImpl::Show]

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
critical
RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: Peter 'vt100' Schwindt, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060719 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060719 BonEcho/2.0b1

Maybe this is related to Bug 280442

Reproducible: Sometimes

Steps to Reproduce:
1. open some website with a javascript download link
2. wait for the download manager window to open
3. see ff crash instantly :]

Actual Results:  
ff crashes most of the time

Expected Results:  
no crash ;-)

TB21190402M, TB21190419Y, TB21190388Q

Well, this doesn't happen every time, but it does very often
(Reporter)

Updated

11 years ago
Keywords: crash
Can you give an example of a site with a "javascript download link"? I tried http://fabforce.net/downloads.php (from the talkback links), but I got no crash, and I don't see anything that looks like a "javascript link" on that site.
(Reporter)

Comment 2

11 years ago
Well, to be exact, I clicked on http://fabforce.net/downloadfile.php?iddownloadfile=2 then on the "Download the File"-button...

I only _guessed_ it had to be something with JS, since I never reached the pages' source code.

It looks like this was only some META REFRESH.

Peter

Comment 3

11 years ago
Peter, can you reproduce this in today's builds? I have a feeling this is the same as bug 345083 (which was fixed by the patch in bug 314549).

Incident ID: 21190402
Stack Signature	0x00000000 01687f5a
Product ID	Firefox2
Build ID	2006071904
Trigger Time	2006-07-20 23:23:04.0
Platform	LinuxIntel
Operating System	Linux 2.6.15.3n
Module	
URL visited	fabforce.net
User Comments	Waiting for some download to happen
Since Last Crash	0 sec
Total Uptime	7 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
0x00000000
DocumentViewerImpl::Show()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/layout/base/nsDocumentViewer.cpp, line 830]
nsPresContext::EnsureVisible()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/layout/base/nsPresContext.cpp, line 1311]
PresShell::UnsuppressAndInvalidate()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/layout/base/nsPresShell.cpp, line 5034]
PresShell::ProcessReflowCommands()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/layout/base/nsPresShell.cpp, line 6947]
ReflowEvent::HandleEvent()
PL_HandleEvent()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/xpcom/threads/plevent.c, line 689]
PL_ProcessPendingEvents()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/xpcom/threads/plevent.c, line 623]
nsEventQueueImpl::ProcessPendingEvents()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/xpcom/threads/nsEventQueue.cpp, line 421]
event_processor_callback()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/widget/src/gtk2/nsAppShell.cpp, line 67]
libglib-2.0.so.0 + 0x4d7ef (0xb79c07ef)
libglib-2.0.so.0 + 0x24e2c (0xb7997e2c)
libglib-2.0.so.0 + 0x28176 (0xb799b176)
libglib-2.0.so.0 + 0x28537 (0xb799b537)
libgtk-x11-2.0.so.0 + 0x12c4e1 (0xb7c624e1)
nsAppShell::Run()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/widget/src/gtk2/nsAppShell.cpp, line 141]
nsAppStartup::Run()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
XRE_main()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/toolkit/xre/nsAppRunner.cpp, line 2396]
main()  [/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/browser/app/nsBrowserApp.cpp, line 62]
libc.so.6 + 0x14eb0 (0xb7482eb0)
Summary: Firefox crashes when waiting for the download manager to open → Firefox crashes when waiting for the download manager to open [@ DocumentViewerImpl::Show]
(Reporter)

Comment 4

11 years ago
Ok, no crashes for a few days, I'll close this one
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

11 years ago
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
(Assignee)

Updated

7 years ago
Crash Signature: [@ DocumentViewerImpl::Show]
You need to log in before you can comment on or make changes to this bug.