text-transform: capitalize does not work when first character is a (

RESOLVED DUPLICATE of bug 208789

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 208789
12 years ago
12 years ago

People

(Reporter: Jeroen Ruijgers, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

when an element has the css property text-transform set to capitalize and the contents start with a ( the alpha-character following it is not capitalized

Reproducible: Always

Steps to Reproduce:
see attachment
(Reporter)

Comment 1

12 years ago
Created attachment 230118 [details]
capitaliezes text in a paragraph
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5.0.x Branch
I'm not actually shure what the actual behavior should be here though it seems correct.

http://www.w3.org/TR/REC-CSS2/text.html#caps-prop specifically says that:

> This property controls capitalization effects of an element's text. Values have the following meanings:

The first character is a "(" so it probably should not be marked but its still open to the debate of weather the word actually begins after the punctuation character.... the specification does not cover that.

Anyone with a bit more insight please reply but I'm guessing this is a wontfix.
This is a duplicate of bug 208789 (e.g. via bug 273360).

*** This bug has been marked as a duplicate of 208789 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.