MSAA information in message listview doesn't match the visible list view headers.

RESOLVED DUPLICATE of bug 356347

Status

RESOLVED DUPLICATE of bug 356347
12 years ago
12 years ago

People

(Reporter: basiphobe, Assigned: mscott)

Tracking

(Blocks: 1 bug, {access})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Thunderbird 1.5.0.5 (20060719)

Instead of pushing all information about the selected message through MSAA, only the details for the visible headers should be pushed through.  

For example, the name value of an OBJ_FOCUS event on a selected message may include something like:

OBJ_FOCUS	 Name="    This is a sample email message  0    email1@xyz.com, email2@xyz.com, "Aaron Smith", email3@xyz.com  10:43 AM    2KB      aaron@xyz.com          285958219  "

The only headers visible, however, are Subject, and Sender. 

Reproducible: Always

Steps to Reproduce:
1. Launch Thunderbird
2. Set message list view headers to be only Sender and Subject (in that order) 
3. Select a message

Actual Results:  
Using an AT tool like Window-Eyes, or MSAA tool such as AccEvent (set to watch OBJ_FOCUS), all of the information about the message is read/displayed rather than just the headers that are visible.

Expected Results:  
Only the message information that matches the visible list view headers should be read/displayed.

The message information coming through MSAA does appear to pay attention to the order of the list view headers, which is nice.

Updated

12 years ago
Keywords: access

Comment 1

12 years ago
shouldn't AT tools use states SHOWING/VISIBLE to decide whether to read it?

please see the discussion in bug 356347
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> shouldn't AT tools use states SHOWING/VISIBLE to decide whether to read it?
> 
> please see the discussion in bug 356347
> 

They do, but I believe state is irrelevant here. The problem is that all the individual fields are being included in the value, rather than only the displayed fields. For example, if I display only the subject and from fields, I would expect only subject and from data to show up in the OBJ_FOCUS value. But, as of right now, even with only displaying the subject and from fields, ALL the data (subject, from, date, size, read/unread status, attachments, etc.) shows up in the value. The data in the value needs to reflect the visible (i.e. displayed on the screen) fields. 

Comment 3

12 years ago
Is this bug a Windows only, or also exists on linux?
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Is this bug a Windows only, or also exists on linux?
> 

To my knowledge, MSAA (Microsoft Active Accessibility) doesn't exist under Linux.
Using at-poke (a linux accessibility diagnostic tool) it looks like this problem exists on linux too. Either thunderbird is not firing the right events when the visible message view list headers change, or at-poke is not listening to those events.

Evan have you tried to recreat this on linux?

Comment 6

12 years ago
I think the original problem - shouldn't expose invisible column - has been fixed in bug 356347.

About firing events, I saw in at-poke that object:state-changed:remove events are always fired, no matter adding or removing column.
I filed bug 368535 for that.

Comment 7

12 years ago
I think this message could be closed, as comment #6 talked.
After a closer review of this bug I note that my comment #5 does not apply here and applies instead to a different problem to do with tree mutations not updating the accessible tree cache (related bug 368835).

I agree with Evan that this bug could be closed. His nice fix for bug 356347 should also solve this problem.

Comment 9

12 years ago
Thanks for confirming this, David.

=> close as dupe of bug 356347
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
OS: Windows XP → All
Resolution: --- → DUPLICATE
Duplicate of bug: 356347
You need to log in before you can comment on or make changes to this bug.