If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Show images": add "This e-mail only" and "Always for this e-mail address"

RESOLVED DUPLICATE of bug 357321

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 357321
11 years ago
10 years ago

People

(Reporter: Zarco Zwier, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060720 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060720 BonEcho/2.0b1

Currently, when one receives an e-mail with remote images, a button is displayed  which, when pressed, shows the remote images.
Currently this button releases remote images for this e-mail only.
I'd like to see an extra option to choose whether to show the remote images once, or every time I receive an e-mail from this contact.

Reproducible: Always

Steps to Reproduce:
1. Receive an e-mail with remote images
2. Open the e-mail message
3. Click the "Show images" button

Actual Results:  
1. The remote images are shown

Expected Results:  
1. When clicking the "Show images" button, a menu is shown with:
- "In this e-mail only" (this behaviour is the current behaviour)
- "Always for this contact" (everytime I receive e-mail with remote images from the same contact, the remote images are displayed)

Comment 1

11 years ago
I just wanted to report this enhancement too. I receive regularly one HTML email and it looks ugly unless I allow images. But I do not want to do it globally, only for this particular domain. Please create some textarea in config holding senders or regexp for domains, that shall always display images.

Comment 2

10 years ago
Fixed by bug 357321.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 3

10 years ago
(In reply to comment #1)
> But I do not want to do it
> globally, only for this particular domain. 

According to http://kb.mozillazine.org/Privacy_basics_(Thunderbird) you can use the mail.trusteddomains preference to do this.

Updated

10 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 357321
You need to log in before you can comment on or make changes to this bug.