SVG text is still incorrectly formatted in FF2b1 under Mac OS

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Martin Hejral, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---
Bug Flags:
blocking1.8.1 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414
Build Identifier: Mozilla/5.0 (....MAC.....; cs; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

e.g. if SVG contain this code:
---
<text font-size="24" font-family="Times" fill="black" >
..........
</text>
---
you will see Times-Italic on the screen



Reproducible: Always

Steps to Reproduce:
<text font-size="24" font-family="Times" fill="black" >
..........
</text>

Actual Results:  
see image

Expected Results:  
see image
(Reporter)

Comment 1

12 years ago
Created attachment 230154 [details]
left: Opera 9-correct # right: FF2 (FF1.5) bad output
(Reporter)

Comment 2

12 years ago
Created attachment 230155 [details]
test case
(Reporter)

Comment 3

12 years ago
I think it is *very* *important* feature if we can use FF-SVG in the real world! (Remember, we still not have SVG fonts implemented.)

There are many other similar problems when using different fonts and font styles (Italic, Bold)...
Duplicate of bug 327522 or bug 311949 perhaps?
Flags: blocking1.8.1?

Updated

12 years ago
Attachment #230155 - Attachment mime type: image/xml+svg → image/svg+xml

Comment 5

12 years ago
ccing a couple of folks who might have an idea on what is going on.
Flags: blocking1.8.1? → blocking1.8.1+
Is this fixed on the trunk?  If so, are there cairo patches that could be ported to the branch?  If not, is it a cairo bug or an SVG-cairo binding bug?

Comment 7

11 years ago
Trunk looks worse on OS-X than branch for this, and generally the trunk cairo font backend for OS-X is pretty broken.

As the simple things this testcase does works fine on the other platforms, likely a cairo bug.

Comment 8

11 years ago
Would love a fix - but since this is not a regression from 1.5 we are taking off the blocker list for FF2.

Vlad - is there any easy Cairo fix here?
Flags: blocking1.8.1+ → blocking1.8.1-

Comment 9

11 years ago
This was fixed to an extent in cairo, in this
http://gitweb.freedesktop.org/?p=cairo;a=commitdiff;h=58265f3508959298eabab55ec28dc6d9516eedc3

the toy api was selecting random faces. However this only fixes things for a small set of fonts, and only works for regular faces - not bold, italic. The underlying problem is the use of the toy font api.

BTW trunk currently shows text in the correct face with the wrong rotation for this testcase, but the fix for that is also in cairo now.

Comment 10

11 years ago
This was fixed on trunk by the cairo update in bug 374462. WFM in
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a5pre) Gecko/20070527
Minefield/3.0a5pre

Rendering is pretty much the same as the opera version in attachment #1 [details] [diff] [review] now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

10 years ago
Everything OK. Many thanks!!!!
---
MAC OS 10.4.10
---
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.4; en-US; rv:1.9b2pre)
Gecko/2007112604 Minefield/3.0b2pre
You need to log in before you can comment on or make changes to this bug.