Closed Bug 345501 Opened 13 years ago Closed 13 years ago

enable auto-save by default

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Bienvenu, Assigned: Bienvenu)

References

Details

(Keywords: verified1.8.1.3)

Attachments

(1 file)

I think in 2.0 we should enable auto-save of drafts by default...now that it doesn't block the UI so much, and has been tested in 1.5...
Karsten, do you want this for SM, in  mailnews.js, or should I put it in all-thunderbird.js?
*** Bug 348790 has been marked as a duplicate of this bug. ***
we might want to clean up some of the bugs with auto-save if we turn this on by default, in particular, the bugs that cause us to leave drafts around, e.g., if you have a compose window open, and exit the app - we leave the draft around. mail.app will prompt you on startup if you want to go back to editing the draft, and I believe Seth filed an RFE for TB to do the same.

If SM doesn't want this pref, I guess they can override it themselves.
Attachment #234030 - Flags: superreview?(mscott)
Attachment #234030 - Flags: superreview?(mscott) → superreview+
fixed on trunk and branch
Status: NEW → RESOLVED
Closed: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
verified fixed for 1.8.1.3 using (Thunderbird 2 RC1) Mozilla/5.0 (Windows; U;
Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0
Mnenhy/0.7.5.0 ID:2007032620

Auto-save is default now.
Duplicate of this bug: 494207
You need to log in before you can comment on or make changes to this bug.