Feed viewer broken with entry.summary is not a function

VERIFIED FIXED

Status

()

--
major
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: ttolonen, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060721 Firefox/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060721 Firefox/3.0a1

instead of the feed's content the following text shows up: [xpconnect wrapped nsIFeedTextConstruct]

Error: entry.summary is not a function
Source File: file:///D:/Program%20Files/Mozilla%20Firefox/components/FeedWriter.js
Line: 181

Error: uncaught exception: [Exception... "'[JavaScript Error: "entry.summary is not a function" {file: "file:///D:/Program%20Files/Mozilla%20Firefox/components/FeedWriter.js" line: 181}]' when calling method: [nsIFeedWriter::write]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://browser/content/feeds/subscribe.js :: SH_init :: line 46"  data: yes]

Reproducible: Always
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Reporter)

Comment 2

13 years ago
This was caused by the fix for bug 344991 (local backout)

Comment 3

13 years ago
I missed a file on checkin for bug 344991 
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060722 Minefield/3.0a1 ID:2006072209 [cairo]

verified
Status: RESOLVED → VERIFIED

Comment 5

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060722 Minefield/3.0a1 ID:2006072216 [cairo]

cannot use "Subscribe Now" button.
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060722
> Minefield/3.0a1 ID:2006072216 [cairo]
> 
> cannot use "Subscribe Now" button.
> 

I've been seeing this too, I think this is a separate issue though. I filed bug 345619 for it.
You need to log in before you can comment on or make changes to this bug.