The default bug view has changed. See this FAQ.

liga not working in Firefox 1.5 under Mac OS X 10.4.7

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
--
major
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: P. Andries, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Compare how the following Tifinagh page 
<http://familleandries.iquebec.com/tifinar/essai-tifinar-avec-ligature.html>
displayed on Mac OS X under Firefox 1.5 with the same file displayed under Windows XP SP 2.

Here is the Mac OS X : 

http://familleandries.iquebec.com/tifinar/firefox-mac-os-x-10-4-7.png

And the Windows XP SP 2

http://familleandries.iquebec.com/tifinar/firefox-windows-xp-sp-2.png
(correct under Windows, with the exception of the title bar which displays white rectangle)

The font used can be found here : 

http://familleandries.iquebec.com/tifinar/hapaxtifinarcarree.ttf



Reproducible: Always

Steps to Reproduce:
1. Download the font http://familleandries.iquebec.com/tifinar/hapaxtifinarcarree.ttf
2. Open the following HTML page http://familleandries.iquebec.com/tifinar/essai-tifinar-avec-ligature.html
3. It displays as 
http://familleandries.iquebec.com/tifinar/firefox-mac-os-x-10-4-7.png
on Mac OS X 10.4.7 it should not but display as in Windows or as in TextEdit on the same Mac machine :

http://familleandries.iquebec.com/tifinar/exemple-dans-textedit.png


Actual Results:  
http://familleandries.iquebec.com/tifinar/firefox-mac-os-x-10-4-7.png

Expected Results:  
http://familleandries.iquebec.com/tifinar/firefox-windows-xp-sp-2.png

Consider the "liga" feature in the OpenType font as in TextEdit, this means no proper Tuareg Tifinagh text can be displayed.
(Reporter)

Comment 1

11 years ago
See below for a similar problem (but for Thunderbird): fails on Mac OS X works on Windows.
https://bugzilla.mozilla.org/show_bug.cgi?id=345281

TextEdit and InDesign works fine on Mac OS X with same data.
http://familleandries.iquebec.com/tifinar/polices-et-clavier.html?2&weborama=-1#TextEdit

Comment 2

11 years ago
I see this on all browsers on my computer except IE that doesn't seem to be able to handle the font at all. Could it be a problem with the font itself (it's a windows true type font)?
Component: General → Layout: Fonts and Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: unspecified → Trunk

Comment 3

11 years ago
(In reply to comment #2)
> I see this on all browsers on my computer except IE that doesn't seem to be
> able to handle the font at all. Could it be a problem with the font itself
> (it's a windows true type font)?
> 

With Mac OS 10.3.9

Comment 4

11 years ago
*** Bug 345281 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

11 years ago
(In reply to comment #2)
> I see this on all browsers on my computer except IE that doesn't seem to be
> able to handle the font at all. Could it be a problem with the font itself
> (it's a windows true type font)?
> 

I don't think so otherwise how do you explain that the font works fine with TextEdit and InDesign on the same machine ?

http://familleandries.iquebec.com/tifinar/polices-et-clavier.html?2&weborama=-1#TextEdit

http://familleandries.iquebec.com/tifinar/exemple-dans-indesign-avec-ligatures-activ%E9es.png

Comment 6

11 years ago
Patrick, the latest trunk Firefox is currently under a large rewrite for graphic and font handling that will be incorporated in FF 3. So your problem might be restricted to the 1.8 core branch, that's the base for Firefox 1.5 and the coming FF 2.0.
Could you check if there's still the problem in the trunk or not ? You can get get it from here :
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-3.0a1.en-US.mac.dmg
Warning : It can be unstable.

I confirm as the same font works well with FF under Windows.

Patrick, the bug is that with the ZWJ (zero width joiner) the application should check the liga feature in the opentype table in order to known it has to use the joined glyph for the sequence "U+2D59 U+200D U+2D5C" ? Right know, I wonder if the problem is more than FF doesn't take into account ZWJ or doesn't take into account the liga table.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: liga feature not working in Firefox 1.5 under Mac OS X 10.4.7 → liga not working in Firefox 1.5 under Mac OS X 10.4.7
Hmm, if the problem is with ZWJ this might be related to bug 324615 and/or bug 280936. I have a patch for that which works on Linux, but I still need to do cross-platform testing.
(Reporter)

Comment 8

11 years ago
Tried Minefield (the latest-trunk), it does not solve the problems.

They are two types of ligatures in the font :

+ those involving ZWJ 
+ and those that do not ;-)

Both of them seem to fail in Firefox 1.5. on Mac OS X 10.4.7

Long comparison of which tools work and don't work with this font here <http://hapax.qc.ca/polices-et-clavier.html> (in French).

The OpenType features found in the font are here : <http://familleandries.iquebec.com/tifinar/hapaxtifinarcarre.fea>.

Note that they are also kern and ccmp features.
(Reporter)

Comment 9

11 years ago
Any news on this bug ?

Comment 10

11 years ago
There's an *unofficial* 1.8 branch build with the patch for bug 121540 applied  by Yamashita-san. He may give the url where you can download and test it (to see if it solves the problem. It may not if bug 280936 is the real cause of this bug).


As for FF 3.0, thebe stuff hasn't been landed yet for Mac OS X (see bug 328116 and other related bugs) so that as of now, FF 3.0 (-to-be) is not much different from FF 2.0b1 and FF 1.5 in terms of complex script support.

Comment 11

11 years ago
I guess the culprit is OSX's Unicode support. According to this release note
http://developer.apple.com/releasenotes/CoreFoundation/CoreFoundation.html
Tiger supports up to v4.0.1, but Tifinagh was included at v4.1.
(Reporter)

Comment 12

11 years ago
>------- Comment #11 from makotoy@ms.u-tokyo.ac.jp  2006-08-14 23:17 PDT -------
>I guess the culprit is OSX's Unicode support. According to this release note
>http://developer.apple.com/releasenotes/CoreFoundation/CoreFoundation.html
>Tiger supports up to v4.0.1, but Tifinagh was included at v4.1.

How do you account then for TextEdit to work quite fine ? 

See http://familleandries.iquebec.com/tifinar/exemple-dans-textedit.png

(Other applications also work like Safari, see http://hapax.qc.ca/polices-et-clavier.html#Safari, 3 camels is perfect support)

You don't need to know really anything about Tifinagh to display this. Just respect OpenType liga feature and not to interfere (unknown character at this version of Unicode).

Comment 13

11 years ago
Looks like I had some error in installing the font. Now it's half-working on my machine: the ligature on the last character is working, while the one that should sit above U+2D35 is dissapearing.  The latter reminds me of a similar problem for C-caron reported in bug 121540. I suspect it might be an error of text engine overall. Even in the TextEdit, ligas above the characters are not rendered in the topmost line, right below the ruler. Since we draw the text line by line specifying the exact target range, it's likely we are getting that sort of clipping for every line in Gecko.

Comment 14

11 years ago
FYI, this problem does not occur for Minefield build with cairo-cocoa toolkit.  Because the default toolkit is still old gfx-mac, no wonder this still persists on chevron nightly builds.

Comment 15

11 years ago
Is this bug for trunk or branch? If it's for branch as its summary implies, (i.e. FF 1.5 or 2.0) there's no chance it'll be fixed in time for FF 2.0. If it's for trunk (as 'version' field indicates), it'll be fixed by the time FF 3.0 is released with cairo turned on and made the default build option. (bug 328116)

Depends on: 328116

Comment 16

11 years ago
OK, so it's WONTFIX for 2.0 (too late, too complex) and WORKSFORME with cairo/cocoa builds on which 3.0 will be based.
Would be good if the reporter could check by himself if it's indeed all right on a cairo/cocoa build.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 17

10 years ago
I'm happy to report that the bug seems to be resolved in Firefox (Minefield) 3.0a3pre see: http://hapax.qc.ca/polices-et-clavier.html#Firefox_3.0_Mac_OS_X_10.4.8
or
http://familleandries.iquebec.com/tifinar/exemple-firefox-3.0a3pre.png

(the final ligature is now formed : the + goes inside the rectangle).
You need to log in before you can comment on or make changes to this bug.