The caching of the page is to slow when I use a printer-friendly css layout

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: evangun2001, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

I change the layout of the page with css, ask for print(), and then put the first layout back. That is :
layout(); print(); layoutoutreverse();
it works in IE because it remembers the state of the page at the moment print() is first called. But Firefox doesn't, it prints the page at the state when it is ready to  print. And I have to write :
layout(); print(); setTimeout("layoutoutreverse();",10000);
which is annoying and non-esthetic. Otherwise it will print the layout when it has already been reversed.
Thank you very much.

Reproducible: Always

Actual Results:  
I said it all, thank you

Expected Results:  
It should have remembered the state of the page at the exact time where print() has been called. Just like window.onbeforeprint can do it in IE. This function id really handy along with onafterprint(), it would be great if it could be reproduced.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 2

12 years ago
Hello,
yes it is still happening on FF 2.0.0.4
I can provide a test URL by email if need be :)
Thank you

Updated

12 years ago
Whiteboard: CLOSEME 06/27
Version: 1.5.0.x Branch → 2.0 Branch
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

9 years ago
Hello,

The issue is now handled much better.

In Firefox, if I do :

layout(); window.print(); layoutoutreverse();
-> this will still not work

layout(); window.print(); setTimeout("layoutoutreverse()", 1);
-> this will now work, layout is back right after print. That's much better than waiting a few seconds without knowing exactly when the browser will be ready.

So I guess this issue is fixed. However, just to let you know, there is still some work to do to match the perfect behavior of IE on that matter (perfect behavior for what I want to do at least):

window.onbeforeprint=layout;
window.onafterprint=layoutreverse;
window.print();
-> this is perfect because at no time, the user sees the trickery I do on the layout to make it printable. On Firefox however, when the print window pops up, the page in the background is "frozen" on the printable layout. As if printing was asynchronous in IE and synchronous in Firefox.

Thanks
Resolution: INCOMPLETE → FIXED

Updated

9 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.