Shadow outline of menu remains after menu closes with NVidia virtual desktop system

UNCONFIRMED
Unassigned

Status

()

Core
General
UNCONFIRMED
12 years ago
7 years ago

People

(Reporter: Ken Monk, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.4) Gecko/20060516 Thunderbird/1.5.0.4

After opening a menu and moving on the shadow of that menu remains until I reboot.  It may just be a function of the graphics card and driver software that I am using.

The card is an nVidia Geforce FX5700, 256MB, 8x AGP, TV out, DVI.  The drivers appear to be version 6.14.10.5303.  A possible link is that I have enabled the multiple desktops that these drivers allow.  However, Thunderbird is the only program of the many I run that displays this problem.


Reproducible: Sometimes

Steps to Reproduce:
Can't guarantee to reproduce as doesn't happen with any consistency that I can identify.

Actual Results:  
The only extensions I have installed over the default installation are Talkback  and Signature Switch.  The latter was the only one added from the original installation and the problem was present before that installation.


I have just (for the first time to my memory) had the same effect in Firefox!  I switched desktops from the Firefox to Thunderbird to check the extension list.  When I came back the Firefox menu had disappeared but has left its shadow outline behind!
(Reporter)

Comment 1

12 years ago
I can now reproduce the bug every time, and in both Firefox and Thunderbird (FF/TB), but not other programs.  If I leave a menu dropped down and change desktops then come back to the first with the disoplayed menu, that menu is still there.  Whatever I then do , I end up with the shadow outline of that menu.

The difference between FF/TB and all other (tried) programs is that FF/TB leave the original menu displayed on return.  No toher program I have tried soes this - they all come back to the program wothout that menu left being displayed.

I hope this is more helpful than the original information provided.

Comment 2

11 years ago
Ken, do you still see this problem?  Please comment on whether you changed PCs or are a first time install of thunderbird+firefox, or it was working OK before 2006-07-23.

I have an FX5200 and never see this.  driver version 6.14.10.5216
Assignee: mscott → nobody
Component: General → General
Product: Thunderbird → Core
QA Contact: general → general
Version: unspecified → 1.8 Branch
(Reporter)

Comment 3

11 years ago
I have recently had to rebuild the machine following a memory module failure, so the installation is relatively new - a month or so at this time.  The problem is, however still present and still repeatable as in my second message.

(Having noticed the typos in the second message above, I've tried to check this one rather more carefully ;-) )

Comment 4

11 years ago
my comment 2 was more to the issue of, did you ever not see the problem?

in comment 0 you mention changing desktops. are you using a virtual desktop tool?

please attach a screen shot (png file) to the bug showing the problem.
(Reporter)

Comment 5

11 years ago
I can't remember when I first noticed the problem, but it has always been present after the first spot.

I am using the NVidia virtual desktop system and it seems to be this which causes the problem.  It is only when switching desktops with a menu pulled down in either Firefox or Thunderbird that the problem occurs.

The really strange thing is that I can't get the effect to record in a screen grab.  Both an area and a whole screen have been tried using the screen grab facility in Paint Shop Pro XI, but the shadows refuse to record.

The shadows I get are the shading to the right and below the drop-down menu.

One thing which does seem to be different with this installation is that the shadows are usually only present on the original FF or TB desktop.  They used to be present on ALL desktops.  The only real change is in the versions installed, currently FF is 2.0.0.3 and TB is 1.5.0.10.

In looking up the version numbers above it gets even stranger.  The shadows disappeared when I clicked on the 'Help' menu and haven't come back.  This is definitely different behaviour to previously.  Whether it's the newer versions of FF and TB or the re-installation of XP I am not in a position to tell??!!

I hope this hasn't, therefore, been a waste of your time.

    Ken

Comment 6

11 years ago
for other issues with virtual desktops see 
 https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=virtual+desk&product=Core&product=Firefox&product=Mozilla+Application+Suite&product=Thunderbird&product=Toolkit&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&resolution=FIXED&resolution=INVALID&resolution=WONTFIX&resolution=DUPLICATE&resolution=WORKSFORME&resolution=INCOMPLETE&resolution=EXPIRED&resolution=MOVED&resolution=---&op_sys=All&op_sys=Windows+95&op_sys=Windows+98&op_sys=Windows+ME&op_sys=Windows+NT&op_sys=Windows+2000&op_sys=Windows+XP&op_sys=Windows+Server+2003&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-0=noop&value0-0-0=
especially 
bug 176103
bug 176600
Summary: Shadow outline of menu remains after menu closes → Shadow outline of menu remains after menu closes with NVidia virtual desktop system

Comment 7

10 years ago
I see the same problem after upgrading from Firefox 1.5 to 3.0 RC2.  A rather interesting effect is that when I move the Firefox window, the menu shadows stay in place above the window or desktop!  They even appear above other windows -- I can move a Windows Explorer window between the menu shadows and Firefox.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Windows XP SP1

nVidia GeForce 8600 GT, driver version 6.14.11.6921
nView display mode: single display

Comment 8

10 years ago
Just noticed a couple more things:

The shadows only seem to get stuck if I open one menu and then move my mouse across the menu labels so that each one opens in turn.  If I close the current menu before moving on to another, its shadow will disappear.

If I hover my mouse over the menu labels without opening any of them, the corresponding shadows will disappear completely.  Even after moving the Firefox window, the shadow for each menu will disappear from its old location.

Comment 9

10 years ago
Trevin, you are probably seeing bug 433920, which, although similar, is a different issue.

Comment 10

10 years ago
Well ... I personnel to install the Firefox 3, and remains a shadow, looking in front on the right side and below the pull-down menus. Some my friends also reported that estraneza. one of you has gone too hence, and that was what they did to solve? The interesting that even minimizing the Firefox 3 persists these shadows on the desktop, but once you close the Firefox 3 they also disappear, I believe to be a bug in the program.

http://www.flickr.com/photos/27912568@N07/2603848411/sizes/o/in/set-72157605774453805/

Comment 11

7 years ago
does this reproduce with FF4 or 5 (beta @ http://www.mozilla.com/en-US/firefox/channel/ ) ??

Marcelo your http://www.flickr.com/photos/27912568@N07/2603848411/sizes/o/in/set-72157605774453805/ is gone
(Reporter)

Comment 12

7 years ago
I stopped using the nVidia desktop software after some other problems.  I now use Virtual Dimension.

The problem is now not present.
You need to log in before you can comment on or make changes to this bug.