If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Overflow text is misaligned until right-clicked on.

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Roger Libiez, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060723 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060723 BonEcho/2.0b1

When loading the contents of the page ( example code was reduced as much as possible to demonstrate it ) the text in the overflow box that displays the code gets out of alignment with the line numbers in the column to the left of it.

The text will realign itself properly upon right clicking anywhere inside the larger black area to bring up the context menu. Best observed if scrolled to the bottom of the testcase.

It is ok to ignore the fact that the text will extend below where line 215 is marked. This isn't a big deal because that's probably the result of the original code used to generate this layout. It's the alignment issue itself that's the problem.

Reproducible: Always

Steps to Reproduce:
1. Load testcase.
2. Scroll to bottom.
3. Right-click on the text.
4. Observe the text realign itself.

Actual Results:  
The text shifted upward and became aligned with the numbers on the left column.

Expected Results:  
The text should come out already aligned in the proper manner.

BuildID: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060723 BonEcho/2.0b1 ID:2006072304

This has been checked though with the release versions of Firefox back to 1.5.0.0. It is unknown at this time weather 1.0.x is affected. Opera 9 and IE6 both display the text in the expected manner.
(Reporter)

Comment 1

11 years ago
Created attachment 230352 [details]
Testcase for bug.

Demonstrates the realignment issue.

Updated

11 years ago
Attachment #230352 - Attachment mime type: application/octet-stream → text/html
I can see the bug, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060721 Minefield/3.0a1
It happens when the overflow:auto div gets focus. You can focus it by tabbing into it (which is the way I reproduced it).
A minimal testcase might be useful here.

Comment 3

9 years ago
I can reproduce the bug in Fx2, but not in Fx3.* and trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.