Closed Bug 345766 Opened 14 years ago Closed 13 years ago

Screen reader does not speak all text in install/uninstall dialogs

Categories

(Firefox :: Disability Access, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Firefox 3 alpha1

People

(Reporter: deangelo, Unassigned)

References

Details

(Keywords: access)

Env: Bon Echo nightly build 20070723, both Window Eyes & JAWS.

Description:
Window-Eyes screen reader automatically announces only the first uninstall dialog.  When selecting the "Next" button, the screen reader doesn't read subsequent dialogs, unless you manually instruct the screen reader to read the entire window.

Steps to Reproduce using Windows XP:
1. Start Window-eyes
2. Open Control Panel, Add or Remove Programs
3. Select Bon Echo and select the "Remove" button.  
4. Note that when the first Firefox uninstall dialog comes up, Window-Eyes reads the entire dialog.
5. Tab to the "Next" button and press Enter.
6. Note that when the 2nd uninstall dialog displays, Window-Eyes is silent.
7. Continue through the uninstall... Window-eyes remains silent, until the last panel, where it announces only the "tell us what you thought" item.

Expected Result:
Window-Eyes should announce all text in all of the windows.
Does this also happen during install?
The same happens during the install too!
Summary: Screen reader does not speak all dialogs in uninstall → Screen reader does not speak all dialogs in install/uninstall
Wayne, is this still occurring?
Target Milestone: --- → Firefox 3 alpha1
Mark, Yes I am still seeing the reported problem with the latest nightly bon echo build of 20061128.
Why is this marked Minor? Install dialogs are crucial.
Blocks: keya11y
Severity: minor → major
Flags: blocking-firefox3?
(In reply to comment #5)
> Why is this marked Minor? Install dialogs are crucial.
Because it was filed as minor
Well I'm upgrading the severity. It should not be filed as minor. In fact it's a section 508 issue as well.
Keywords: sec508
Agreed... I was just answering your question. :)

btw: chances are we will be moving to msi's for official win32 builds while still providing the ability to use an exe installer and though the time frame for this has not been decided yet we'd like to do this for Firefox 3.0. The reason we didn't for 2.0 is that the installer needed to support Win98 where msi functionality might not be installed.
Great to know. There may still be issues with a11y on the Linux installer then. Linux a11y is a target for FF3.
bsmedberg removed the Linux installer some time ago.
Okay, if we move to .msi then we can resolve this as WONTFIX if that installer is never to be used again. Otherwise we can downgrade it -- clear the blocking status.
MSI is at risk for Firefox 3, so don't depend on it. As per Aaron's (somewhat confusing!) otherwise clause, I'm clearing the blocking flag. If that was wrong, you know how to renominate it!
Flags: blocking-firefox3?
This was a bit misreported -- the title and focused form control of each dialog is still spoken, but important contextual information that describes each prompts is not. The screen reader user needs to activate the "read current dialog" feature to get all the info.
Severity: major → normal
Summary: Screen reader does not speak all dialogs in install/uninstall → Screen reader does not speak all text in install/uninstall dialogs
During installation, users of Jaws and Window-eyes will hear only the name of the control that currently has focus.  No grouping information is spoken.  For uninstall, the screen-reader doesn't read anything automatically.  If the user presses Next to continue to the next screen, they hear nothing.  As Aaron said, they need to use their screen-readers manual window reading functionality to know that anything has changed.  Of course, they can press tab to cycle through the controls.  This provides a very good reason for switching to MSI for FF 3.  In addition, the radio buttons for installation type and license agreement don't work as they should.  If you use the up-down arrows to make a selection and you select the top radio button, such as Typical or I Accept, pressing tab takes you to the bottom radio button, instead of skipping to the next control.  This is confusing.
 
Tim, I noticed that too -- will you take it up with the right folks at Mozilla to motivate on the MSI issue or fix this?
Blocks: fox3access
(In reply to comment #14)
> During installation, users of Jaws and Window-eyes will hear only the name of
> the control that currently has focus.  No grouping information is spoken.  For
> uninstall, the screen-reader doesn't read anything automatically.  If the user
> presses Next to continue to the next screen, they hear nothing.  As Aaron said,
> they need to use their screen-readers manual window reading functionality to
> know that anything has changed.  Of course, they can press tab to cycle through
> the controls.  This provides a very good reason for switching to MSI for FF 3. 
> In addition, the radio buttons for installation type and license agreement
> don't work as they should.  If you use the up-down arrows to make a selection
> and you select the top radio button, such as Typical or I Accept, pressing tab
> takes you to the bottom radio button, instead of skipping to the next control. 
> This is confusing.
In regards to the "In addition", The Setup Type radio buttons don't behave as you described for me. I can use the up-down arrow buttons to select the type and pressing tab takes me to the next form control outside of the grouped radio buttons and when tabbing back in to the grouped radio buttons the last selected radio button is selected. The license agreement radio buttons do behave strangely for me and that will be fixed via Bug 395404.

When you state, "For uninstall, the screen-reader doesn't read anything automatically." does this apply to all screens?
The new installer works fine, according to Marco Zehe and Tim Keenan.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.