If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Feature enhancements for Download Manager

RESOLVED INVALID

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED INVALID
11 years ago
9 years ago

People

(Reporter: Jackie Liu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060723 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060723 BonEcho/2.0b1

I like the download manager, but it's missing some features I would like to see in later releases.  

Like (listed by priority)....

* some sort of download acceleration system, such as multipart downloading
* a customary "New Download" button/menu item to start a download from a known url 
* some sort of bandwidth throttle so that users can browse web pages while downloading at a reasonable speed


Reproducible: Always




This is NOT a bug...  Just some things I would like to see in future releases.
Bugzilla is not a place for wishlists. Plus all three of your feature requests are either already on file or being discussed on the Wiki (wiki.mozilla.org) or the newsgroups.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

11 years ago
Sorry...I'm a newbie.  But there was a selection for "Enhancement" request on the "File A Bug" page.  So I supposed this would be appropriate (is it?).
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.