bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Registration info not saved

VERIFIED WORKSFORME

Status

()

Core
Networking: Cache
P3
normal
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: Joe Lloyd, Assigned: Gagan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] 1d, URL)

(Reporter)

Description

19 years ago
This is the easiest site to check, but it appears on several sites I host too.
When you log into a site, then hit the back button, all registration information
is lost, and you must log in again.  I've noticed this in the M14 build also.

Comment 1

19 years ago
did you check "save loging" ?

Comment 2

19 years ago
You said that you niticed it in M14 too.  WHat build did you test this?
(Reporter)

Comment 3

19 years ago
The build was the M14 with crypto release.  From the about box:
Mozilla/5.0 (X11; N; Linux 2.2.14-5.0 i686; en-US) Mozilla/m14.

Where is the "save logging" option?  I didn't notice it anywhere in the
prefs.

Comment 4

19 years ago
i meant - when you login, when mozilla asks you if you want to store the login
and password, if you choose yes.

if you choose no, then it will not save the info
(Reporter)

Comment 5

19 years ago
I tried that, it still makes you log back in.  Any other ideas, or am I the only
one who's noticed this?
Single signon works a lot better now than it did then; and if you mean that going 
Back does not keep the contents of forms you've filled in, then I'm fairly sure 
that's a known issue (though I don't have the bug number to hand).

In any case, M14 is too old a build to report bugs against now. The problem you 
are reporting may well have been fixed. Please could you either download a recent 
nightly build, or wait about a week for M15, and then return to the given URL and 
tell us if you still see this problem.

Gerv
(Reporter)

Comment 7

19 years ago
Download the build from 4/9/00.  The problem still exists.

Comment 8

19 years ago
reporter - when you log in, mozilla asks you if you want to save the password
and username. if oyu choose yes, then the next time you go to hotmail.com, the
info is put into the forms,but you do have to manually press "log in" or whatever.
(Reporter)

Comment 9

19 years ago
That's not the problem.  I've tried that.  It's after you log in.  If you check
a message, then hit the back button to return to an inbox, you must log in
again, whether you save the log in information or not.  Hotmail is not the only
place this happens on, it appears on any page where you log-in(slashdot.org is
another example) if you hit the 'BACK' button, you must log in again.
seeing this as well.

--> Networking Cache
Component: Browser-General → Networking: Cache
forgot to assign to the component.
Assignee: asadotzler → gordon
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: jelwell → tever

Comment 12

19 years ago
Gagan, do we store registration info in the cache. I thought that the protocol 
was storing it. 

Comment 13

19 years ago
Probably dependent on the nsIPrompt changes I need to make, and probaby a dup. 
I'll take it.
Assignee: gordon → warren
Target Milestone: --- → M16

Updated

19 years ago
Depends on: 34720
Keywords: beta2
Whiteboard: 1d
this seems to work for me with 2000041708 (m16) and PSM install on win98.

reporter - are you seeing this still?

Updated

19 years ago
Keywords: nsbeta2
(Reporter)

Comment 15

19 years ago
Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i686; en-US; m14) Gecko/20000418 

Can't check on hotmail it just sits there and never finishes loading.  Slashdot
works fine now.  The site we have here in house that still doesn't work is 
http://www.smci.org/forms.  You're welcome to register and try it.  If you enter
a form and hit the back button it looses all information and you must login in
again.
Keywords: beta2

Comment 16

19 years ago
[nsbeta2+]
Whiteboard: 1d → [nsbeta2+] 1d

Comment 17

18 years ago
Fix checked in. Please give it a try.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

18 years ago
With the linux build from 5/18 it's still there

Comment 19

18 years ago
I'm also hanging on linux (but with today's build) on the hotmail site so I 
can't check it. 

When I go to http://www.smci.org/forms , login, and press back the location 
information is lost but my name and pin is saved.  

re-opening
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 20

18 years ago
My password seems to be saved for other pages. I don't know what's up with this 
one. Maybe it's doing something weird with cookies or headers. Passing this off 
to Gagan. I think single sign-on is working fine.
Assignee: warren → gagan
Status: REOPENED → NEW
(Reporter)

Comment 21

18 years ago
Both sites work for me with the M16 build(Windows and Linux).  Information is 
restored when the back button is pressed.

Comment 22

18 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.
(Assignee)

Comment 23

18 years ago
Clicking submit on any form and then hitting back button does not throw away the 
registration info. In all cases it depends on the javascript on the page (which 
resets values in onLoad as in the case in point) Hotmail resets its page (even 
on 4.* browsers)

Other than that, the functionality to store and redisplay registration info when 
the back button is hit works fine for me on all three platforms. Hence marking 
this as WORKSFORME. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 24

18 years ago
verified:
WinNT 2000072811
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.