Only show the close button on the active tab

RESOLVED WONTFIX

Status

()

Firefox
Tabbed Browser
RESOLVED WONTFIX
12 years ago
11 years ago

People

(Reporter: Simon Bünzli, Unassigned)

Tracking

2.0 Branch
Points:
---
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
... which is what we do anyway when more than a few tabs are visible and which would prevent accidental data loss when accidentally hitting the close button while trying to focus a background tab.

Not sure whether this has been discussed already - but I haven't found a related bug and there's not much of an argument about this in bug 324227. At least the summary linked in the URL seems to suggest to reconsider and possibly change the default value of browser.tabs.closeButtons to 0.
> ... which is what we do anyway when more than a few tabs are visible

right, and that is controlled by the browser.tabs.tabClipWidth pref (set to 140 px).

perhaps ben, beltzner, or mconnor can elaborate on why the default for browser.tabs.closeButtons is 1.

> ... which is what we do anyway when more than a few tabs are visible

right, and that is controlled by the browser.tabs.tabClipWidth pref (set to 140 px).

perhaps ben, beltzner, or mconnor can elaborate on why the default for browser.tabs.closeButtons is 1.

Having closebuttons on the background tab allows users to close background tabs in a discoverable fashion.  The user testing that was conducted around closebuttons indicated that accidental clicking of closebuttons was around 0.1-0.2% while tabs were > 120 px, so there's no real benefit to active tab only in the main case.  Especially with Undo Close Tab, this is very much a corner case.

Beyond the now-slim potential for dataloss, is there any other rationale?
(Reporter)

Comment 4

12 years ago
Further reasons are:
* Consistency with the many-tabs case ("where'd my close buttons go?")
* The tabs look IMO less cluttered with less UI elements on them
* Why should we make closing background tabs any easier at all (the context menu seems discoverable enough for those who absolutely need this)?
* There's more room for tab titles when the tab bar is filled (before tabClipWidth is reached).
Flags: blocking-firefox2?
(In reply to comment #4)
> Further reasons are:
> * Consistency with the many-tabs case ("where'd my close buttons go?")

Using larger tab sets seems to be the minority case, I think we hit activeonly around 7-8 tabs, which is getting into the long tail of usage.  We shouldn't worry about being consistent with the edge case, that's thinking in the wrong direction.

> * The tabs look IMO less cluttered with less UI elements on them

Sure, but why have closebuttons at all then?

> * Why should we make closing background tabs any easier at all (the context
> menu seems discoverable enough for those who absolutely need this)?

Its a common task, and pretty common as a task, based on studies and anecdotal observation.  Making it obvious that you can do it improves the experience.

> * There's more room for tab titles when the tab bar is filled (before
> tabClipWidth is reached).

An extra letter or two isn't that much more usable, so this is minor.

Comment 6

12 years ago
Why not use invisible close buttons with activation through on-mouse-over like they have in Azureus? You only see the close button when you move your mouse over the specific tab. 
Discussed this again in 1.8.1 triage, this is a WONTFIX, for reasons already given.

As a note, the current iteration of the Windows/Linux theme has very subtle background closebuttons, which really makes it a lot cleaner without impacting functionality.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Flags: blocking-firefox2? → blocking-firefox2-
Resolution: --- → WONTFIX
(In reply to comment #6)
> Why not use invisible close buttons with activation through on-mouse-over like
> they have in Azureus? You only see the close button when you move your mouse
> over the specific tab. 

This is even worse, since it becomes possible to target an area that looks like it's "select this tab" but turns out to be "close this tab" when you actually click. Eclipse used to do this -- maybe even still does! -- and it was a source of many bugs and many more headaches.

(Reporter)

Comment 9

11 years ago
FYI: IE7 does exactly what this bug asked for. This might at least get us some indirect user feedback on this request...
Duplicate of this bug: 392998
Fwiw, my brother accidentally closed background tabs because of this. He was pretty distressed by it.
Undo Close Tab is not an option, he didn't even know about it. And he didn't find it a solution to the problem.

I know that closing background tabs is a common task. That's why you can middle-click to close them.
New users who just found out how to use tabs, should not be confronted with this kind of dataloss issue.
You need to log in before you can comment on or make changes to this bug.