Closed Bug 345859 Opened 16 years ago Closed 16 years ago

[Mac] Use/Installation of spell check xpi's broken.

Categories

(Core :: Spelling checker, defect)

PowerPC
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 343901

People

(Reporter: patrick.hendriks+bugzilla, Assigned: mscott)

Details

With the fix for bug 151040 in place we don't use the spell checker xpi's and its core code for trunk builds on Mac OS X anymore. 

Spell checking therefore becomes limited to the dictionaries that follow with OS X and any spell check xpi's that are added will not be exposed for use to the user.

See bug 151040 comment 110 
"Anyway, my current OS X install doesn't provide a Norwegian spell checker. For
a while i could add the necessary spell.xpi files to add that functionality. 

However, since we hooked in to the the spell checkers provided by OS X, i can't
seem to use the spell check functionality by the xpi files anymore. They got
installed successfully but i'm not able to activate them. "
Is this in Camino or Tbird/Ffox? Bug 151040 was Camino-only. See also bug 343076
(In reply to comment #1)
> Is this in Camino or Tbird/Ffox? 


As Mark put it so eloquently: foxes and birds.

See bug 151040 comment 112 and bug 151040 comment 114.

It's very well possible that in part this is my first bug report filed before the bug occurs ;)

Either way, imho mac builds using osxspell shouldn't break myspell functionality.

Bug 151040 was entirely innocent, this was caused (mostly intentionally) by bug 216382

*** This bug has been marked as a duplicate of 343901 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.