Search engine update system is leaking nsXPCWrappedJS and XPCWrappedNative objects

RESOLVED FIXED

Status

()

Firefox
Search
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Adam Guthrie, Unassigned)

Tracking

({memory-leak})

Trunk
x86
Linux
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

12 years ago
In bug 345530 we tracked down one of the leaks to the search engine update system landing. See bug 345530 comment 0 for leak numbers.

I heard Gavin and Joey say something about timers in the update system... maybe those are related.
(Reporter)

Updated

12 years ago
Summary: Search engine update system is leaking nsXPCWrappedJS objects → Search engine update system is leaking nsXPCWrappedJS and XPCWrappedNative objects
(Reporter)

Comment 1

12 years ago
*** Bug 345530 has been marked as a duplicate of this bug. ***
No longer blocks: 345530

Comment 2

12 years ago
What about pulling the timeout registration outside of the object implementing the callback?  I'm just guessing here, but that seems to be the most reasonable way we could leak here.
http://lxr.mozilla.org/seamonkey/source/browser/components/search/nsSearchService.js#2858
(Reporter)

Comment 3

12 years ago
Joey, could you make a patch that does what you mentioned in comment 2? I'd be willing to test it and report back as to whether it fixes the leaks or not.

Comment 4

12 years ago
Created attachment 233682 [details] [diff] [review]
shot in the dark

Adam, this is the patch that I was describing.
(Reporter)

Comment 5

12 years ago
Comment on attachment 233682 [details] [diff] [review]
shot in the dark

Unfortunately, this doesn't seem to fix the leaks. 

FWIW, earlier today (before I commented here) I commented out the entire engineUpdateService var and the everything that referenced it; e.g. SearchService._init() and this fixed the leaks.
Attachment #233682 - Attachment is obsolete: true
I suspect that the patch in bug 349379 will fix this.
(Reporter)

Comment 7

12 years ago
Fixed by bug 349379.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.