Incorrect end date shown on tooltip and edit event dialog box for all day events

RESOLVED WORKSFORME

Status

Calendar
Calendar Views
--
major
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: mike, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

When setting an end date for a calendar item that is "All Day" the date shown is 1 day before the true end date.

Reproducible: Always

Steps to Reproduce:
1.Create a one day all day event
2.Publish calendar
3.Reload calendar off of webdav server
4.Hover mouse over all day event
5.Observe that the day is date for previous day(on end date)
6.Double click event
7.Observe end date is precedes true end date by one day

Actual Results:  
See subject

Expected Results:  
Expected dialogbox for edit event to show true end date and tooltip to display true end date

version .3a1 & 2

Comment 1

12 years ago
Maybe a duplicate of bug 335882?  Either way landing bug 331145 will help a lot.
I have some trouble to understand exactly what you mean. As I understand you: You have an all day event, e.g. on 26-Jul-2006. In the edit dialog start and end date is shown as 26-Jul-2006. But in the tooltip the event is shown as 26-Jul-2006 00:00 to 27-Jul-2006 00:00 instead?

Does the problem exist in current Sunbird/0.3a2+ builds from http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-trunk/ ?

Updated

12 years ago
Keywords: dataloss

Comment 3

12 years ago
This either blocks 0.3 or should be closed.  Need some QA help here.
Keywords: qawanted
Mike, Bug 331145 was fixed recently. 
Does the issue still exist with current nightly builds of Sunbird?
WFM using
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060909 Calendar/0.3a2+

The date in the tooltip of the event loaded off the WebDAV server is correct.

Reporter,
If you can reproduce this bug using the latest nightly version of Sunbird, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Keywords: dataloss, qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.