Software Updater progress screen should be branded

RESOLVED WONTFIX

Status

()

Toolkit
Application Update
RESOLVED WONTFIX
12 years ago
7 years ago

People

(Reporter: Michael Clackler, Unassigned)

Tracking

unspecified
All
Windows XP
Points:
---
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060725 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060725 Minefield/3.0a1

The Updater program displays an unbranded screen saying "Firefox is installing your updates and will start in a few moments ..."  There is no branding of the screen at all.  The lack of branding looks a little unprofessional and in this day and age looks like a spyware program is installing.  The screen should be branded following the changes in bug 341697.

Reproducible: Always
The wizard of 341697 is not actually related to updater - the former is a XUL/JS confection, and the latter an executable that runs natively on the platform (while the app is shutdown). 
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> The wizard of 341697 is not actually related to updater - the former is a
> XUL/JS confection, and the latter an executable that runs natively on the
> platform (while the app is shutdown). 

Understanding this, the Updater executable would look much more polished with branding of the type used in bug 341697.  While Updater is "not really" Firefox per say, the program is a part of a built-in feature, is called from the program, and has no other use except as part of Firefox.

Having an unbranded form appear saying simply something is installing is a little unnerving especially when using a browser.  With past experiences on IE (years ago...), such an unbranded form with no way to cancel saying something was installing was always some type of malware.  For users new to the experience of Firefox, this basically blank form might be a little alarming.

The software update feature is one of the most "pushed" features, and this form should appear to be part of Firefox with the appropriate branding (icons).

(Reporter)

Comment 3

12 years ago
requesting blocking 2.0 since this completes the software update UI branding started in bug 341697 which was blocking 2.0
Flags: blocking-firefox2?

Comment 4

12 years ago
I don't think this is a bad thing, but it's very difficult and there's no way it's going to make FF2.
Status: UNCONFIRMED → NEW
Ever confirmed: true
What Benjamin said is true, this would be nice to have, but major changes to the updater app are out of scope for six days until beta2
Flags: blocking-firefox2? → blocking-firefox2-
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
limi and faaborg, need a ux decision on this. My personal opinion is we shouldn't do this.
Best fix is silent updates :)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.