Implement history (recent searches) in the google search bar

RESOLVED WONTFIX

Status

Camino Graveyard
Toolbars & Menus
--
enhancement
RESOLVED WONTFIX
12 years ago
3 years ago

People

(Reporter: froodian (Ian Leue), Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Details

(Reporter)

Description

12 years ago
We've been getting a lot of feedback (on feedback) recently with people requesting some sort of search history in the search bar.  Safari uses the drop-down menu for this, but we have alternate search engines there, so obviously that choice is out.

I've been thinking about this, and I think it'd be nice to expose this in a similar method as the terminal, where up and down scroll you through your history.  Of course, in Mac OS X, up and down go to the beginning and end of textfields, so that's less than ideal.  Instead (and I'm 'shamed to admit it), I think it would be best to implement this like Colloquy, using option-up and option-down.

It'd be nice for the people who want it, and non-existent for those who didn't - the best sort of feature.

Since the user can't clear it manually, I propose that this history have the same persistence conditions as session history.

Comment 1

11 years ago
I also think this is a good idea in general, particularly because it's an issue (or perceived issue) in having parity with Safari. Implementation details can be figured out later.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.