Bug 345984 (doubleload)

Browser loads page 2 times if the url is used for the 1st time

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Gideon, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Mozilla/1.5.0.4

If you browsw on a asp site that can add products in a shopping basket and you add artikle 12345 the result will be that you add it twice. The browser opens 2 times http://www.lala.com/addtobasket.asp?art=12345 thus ads 2 times te same artikle. Ones this same url is used and you add another 12345 to the basket the browser correctly adds only 1. But if you add 23456 the problem reocurs.

Reproducible: Always

Steps to Reproduce:
1.Call gideon to start the server +31 6 50 65 28 49
2.surf on www.splurk.nl
3.choose B ekabeling in the menu
4.Enter Xboxx in the searchfield
5.press cursor right (you will see that te page loads 2 times and thus the cursor moves 2 places to the right.
6.press cursor left (again the site will be fetched 2 times)
7.press cursor right (now the cursor moves only 1 place thus the site is 
fetched only one time.
tip. I programmed a counter that inc's by 1 every time the site is opened in a session (your session)
8. Empty the cache and you can try it again.



Expected Results:  
The software must NEVER reopen the same url twice because now i have to program 
a lot of **** in my webshop because of your browser.
(Reporter)

Updated

12 years ago
Alias: doubleload
I appreciate the test case, but one that doesn't require a phone call, espically an international one, would be nice.

Have you tried to reproduce this with a recent nightly test build? You can download one at http://www.mozilla.org/developer
From an email recieved by the reporter:

>I already found out that the error occurs only when the scripting of the site is relatively long.
>In MS-IE and a former version of Firefox the problem does not occur.

>The following tag was the problem:
><meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
>In my site there was some javascript before this tag aswel behind.
>I think that Firefox automaticly reloads the page when this tag occurs after
>possibly visible content so that all content befor the tag will be displayed in 
>the same charset. This might give problems to other sites. I can imagin that
>other programmers also put some javascript before this tag.

(Just for the record.)
Severity: critical → major
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch
works for me with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a6pre) Gecko/20070626 Minefield/3.0a6pre ID:2007062604

-> Closing as works for me because of missing feedback if this is still reproducible in the latest release (Firefox 2.0.0.4) or Trunk Build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.