Closed Bug 346073 Opened 14 years ago Closed 14 years ago

Address Book does not support text selection/copying to clipboard

Categories

(Thunderbird :: Address Book, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 96968

People

(Reporter: alexander.zink, Assigned: mscott)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5
Build Identifier: Mozilla Thunderbird Version 1.5.0.4 (20060516) de

I often need to copy parts of address book cards (or the whole content of a card) to the clipboard to send the information it via mail or to transfer it into other applications.

However, if I select a card from the contact list within an address book, I cannot select and/or copy any text in the detailed card view (lower pane). The only option I have is to double click the card and then select/copy ever single item individually from the edit dialog into the clipboard.

Reproducible: Always

Steps to Reproduce:
Select an address book card in three-pane-view and try to select/copy some information from the lower pane.


Expected Results:  
It should be possible to at least select text in the detailed card view pane and copy it to the clipboard (optionally the whole content at once)!


As an improvement, just selecting one or multiple cards from the list and pressing Ctrl-C might copy the content of these cards into the clipboard (as plain text) for further processing in other applications. The clipboard might even take multiple representations of the card content (e.g. plain text, vCard, XML, etc.).

The (default) plain text format might even be configurable in the preferences by a string including place holders for new-line characters and the individual data items.
Also, it is quite hard to access a list. A trick is to select them and drag'n'drop them to a msg body. Copy & Paste (plain text) is necessary copying out of the adress book.
> However, if I select a card from the contact list within an address book, I
> cannot select and/or copy any text in the detailed card view (lower pane).

This part is a duplicate of core address book bug 96968.

> As an improvement, just selecting one or multiple cards from the list and
> pressing Ctrl-C might copy the content of these cards into the clipboard (as
> plain text) for further processing in other applications. The clipboard might
> even take multiple representations of the card content (e.g. plain text, vCard,
> XML, etc.).
Duplicate of bug 339227 and bug 42085 (the second of these should implement cut/copy/paste).

Duping to bug 96968 as that appears to be the main issue here.

*** This bug has been marked as a duplicate of 96968 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
*** Bug 346080 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.