Address Book does not support text selection/copying to clipboard

RESOLVED DUPLICATE of bug 346073

Status

--
enhancement
RESOLVED DUPLICATE of bug 346073
12 years ago
12 years ago

People

(Reporter: alexander.zink, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5
Build Identifier: Mozilla Thunderbird Version 1.5.0.4 (20060516) de

I often need to copy parts of address book cards (or the whole content of a card) to the clipboard to send the information it via mail or to transfer it into other applications.

However, if I select a card from the contact list within an address book, I cannot select and/or copy any text in the detailed card view (lower pane). The only option I have is to double click the card and then select/copy ever single item individually from the edit dialog into the clipboard.

Reproducible: Always

Steps to Reproduce:
Select an address book card in three-pane-view and try to select/copy some information from the lower pane.


Expected Results:  
It should be possible to at least select text in the detailed card view pane and copy it to the clipboard (optionally the whole content at once)!


As an improvement, just selecting one or multiple cards from the list and pressing Ctrl-C might copy the content of these cards into the clipboard (as plain text) for further processing in other applications. The clipboard might even take multiple representations of the card content (e.g. plain text, vCard, XML, etc.).

The (default) plain text format might even be configurable in the preferences by a string including place holders for new-line characters and the individual data items.
Duplicate of your identical bug 346073

*** This bug has been marked as a duplicate of 346073 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.