beneficialcard.co.uk - No access to online bank account using Firefox. Works OK with IE.

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
12 years ago
4 years ago

People

(Reporter: t.wix, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5

www.beneficialcard.co.uk Home screen comes up in basic text only - no artwork or pictures. Sign-in boxes are basic text. After signing-in, the second screen is also basic text only with two options 'register as new customer' or 'proceed'. Clicking 'proceed' returns me to the 'Home' screen. This is the only website I use that has this fault using Firefox, but it works perfectly using Internet Explorer.

Reproducible: Always

Steps to Reproduce:
1.Type in the website address and 'go'
2.Sign in
3. No third step

Actual Results:  
Returns to home page

Expected Results:  
Access to my card account

Your site is far too technical for me - loads of techno-babble that takes hours to trawl through. I failed to find anything that might lead me to a simple fix, which you probably already have - just give me a clue, please. Fortunately I can get access through IE but I'd like to use Firefox.

Comment 1

12 years ago
Anthony, this is because they are sending their css stylesheet with the wrong mimetype and are using Standards compliance mode. If you look in the javascript console (under the tools menu) you will see:

Error: The stylesheet http://www.beneficialcard.co.uk/common/bene_styles.css was not loaded because its MIME type, "application/x-pointplus", is not "text/css".
Source File: http://www.beneficialcard.co.uk/
Line: 0

There are two fixes for this they can make.

1. Remove the DOCTYPE from their documents. This will place Firefox in Quirks mode where it will ignore the mimetype of the css files.

2. Fix their servers to send the proper mimetype of text/css for css files.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: No access to online bank account using Firefox. Works OK with IE. → beneficialcard.co.uk - No access to online bank account using Firefox. Works OK with IE.

Comment 2

12 years ago
err, damn. meant to send to tech evang.
Assignee: nobody → english-other
Component: Download Manager → English Other
Product: Firefox → Tech Evangelism
QA Contact: download.manager → english-other

Comment 3

12 years ago
Anthony, can you contact your bank, point them to this bug and ask them to fix their content? Thanks.
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Anthony, can you contact your bank, point them to this bug and ask them to fix
> their content? Thanks.
> Will do - thanks for the help.

Updated

11 years ago
Blocks: 124594

Comment 5

11 years ago
Looks like they fixed it; the CSS loads properly in both Camino trunk and Firefox 2 now.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.