underscores should not be allowed in CSS identifiers

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: dbaron, Assigned: pierre)

Tracking

({css1, css2})

Trunk
x86
Linux
css1, css2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

DESCRIPTION:  According to the CSS1 and CSS2 grammar, underscores should not be
allowed directly within identifiers (they must be escaped).  Mozilla is
currently allowing them within identifiers (but not at the start).  Unless this
is going to be changed in CSS3, this should probably be fixed, at least for
strict mode.

STEPS TO REPRODUCE:
 * load http://www.people.fas.harvard.edu/~dbaron/css/test/xmltypesel

ACTUAL RESULTS:
 * the fourth test line is red

EXPECTED RESULTS:
 * it should be black

DOES NOT WORK CORRECTLY ON:
 * Linux, mozilla, 2000-04-05-08-M15
Keywords: css1, css2
Created attachment 7277 [details]
additional testcase
Summary: underscores not allowed in CSS identifiers → underscores should not be allowed in CSS identifiers

Comment 2

19 years ago
non-essential for m16
Target Milestone: --- → M17
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Although we would ideally like to fix this for RTM, enforcing correct usage 
(fixing this bug) is a lower priority than enabling correct usage (which we do 
already in this case). Since there are other bugs where we're currently not yet 
enabling correct usage, we can FUTURE and relnote this if time runs out.
(Assignee)

Comment 4

18 years ago
Who did fix that without telling me :-) ? David? Marc?
Marking WorksForMe.

Interestingly enough, last week I closed as Invalid a bug filed by someone who 
was complaining that underscores were not supported.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
I thing David fixed this a month or more ago when he did some CSSParser 
reworking. I'm not positive, but that is my guess. Do you agree, David?
No, Marc, you fixed this in a checkin on May 4, checking in a patch contributed 
by VYV03354@nifty.ne.jp .

Comment 7

18 years ago
Yup - David's right. It was bug 38179. That was a dup of this one.

Comment 8

18 years ago
Adding 'verifyme' keyword
Keywords: verifyme
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
This bug went from being a valid NEW bug to being a valid ASSIGNED bug to being
a DUPLICATE bug to being a FIXED bug to being an INVALID bug.

However, VERIFIED that it is WORKSFORME in that David's currently invalid 
testcase would pass if it was fixed.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.