attribute parameter 'johndoe@company.tld' is not a hash ref at Bugzilla/Auth/Verify.pm line 112

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
User Accounts
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Wurblzap, Assigned: Max Kanat-Alexander)

Tracking

2.23
Bugzilla 3.0
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
If I log in to Bugzilla using a different case for my login than what's in the database (eg. johndoe@company.tld instead of the current profiles table entry JohnDoe@company.tld), I get "DBI::db=HASH(0x22058a8)->do(...): attribute parameter 'johndoe@company.tld' is not a hash ref at Bugzilla/Auth/Verify.pm line 112."

This is because two things are amiss in Bugzilla/Auth/Verify.pm:
Firstly, it needs to ignore the case when comparing logins here:

    # Now that we have a valid User, we need to see if any data has to be
    # updated.
    if ($username && $user->login ne $username) {

Secondly, it needs to supply undef to $dbh->do a couple of lines further down.
(Reporter)

Updated

12 years ago
Summary: attribute parameter 'mschumann@inconso.de' is not a hash ref at Bugzilla/Auth/Verify.pm line 112 → attribute parameter 'johndoe@company.tld' is not a hash ref at Bugzilla/Auth/Verify.pm line 112
(Assignee)

Comment 1

12 years ago
Ah, yes, that definitely needs to be fixed. Patch coming up.
Assignee: user-accounts → mkanat
(Assignee)

Comment 2

12 years ago
Created attachment 231064 [details] [diff] [review]
v1

Thank you, Marc! That also explains how sometimes we were reaching that segment of code when it *really* should not have been reached.
Attachment #231064 - Flags: review?(wurblzap)
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

12 years ago
Attachment #231064 - Flags: review?(wurblzap) → review+
(Reporter)

Updated

12 years ago
Flags: approval?
Flags: approval? → approval+
(Assignee)

Comment 3

12 years ago
Checking in Bugzilla/Auth/Verify.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Auth/Verify.pm,v  <--  Verify.pm
new revision: 1.4; previous revision: 1.3
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 4

12 years ago
*** Bug 353521 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.