When I search content in a xml file, not everything is found

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: craquerpro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME - 06/29, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; es-ES; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

When searching in XML content, I only get results in tag names and attributes are found

Reproducible: Always

Steps to Reproduce:
1.Open an URL with XML content in the browser
2.Press Ctrl+F
3.Find some text

Actual Results:  
Finds only tag and attribute names.

In this xml fragment:

<mytag b="hello">hi</mytag>

I can find "mytag", "hello" but no "hi"

Expected Results:  
Find any kind of content, including text nodes.

Searching in the view source does work
This is wfm with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

I can see bug 263049, though.

Comment 2

12 years ago
I can confirm this behavior at

1. Go to http://fedoraproject.org/buildgroups/development/i386/buildroots.xml
2. C-f gettext
3. You see "Phrase not found", even though the phrase is on the page.

Firefox 2.0

Comment 3

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/2007051502 Firefox/2.0.0.4

This WFM.  Using the URL in comment #2, I can never get Firefox to the point where it allows you to search tags but not the content between the tags.  In fact, I can only reproduce, in certain situations, the opposite behavior (see bug 285594).

Reporter, can you verify whether you still see this specific problem in the latest release of Firefox when using a clean profile?

http://kb.mozillazine.org/Profile_Manager
Whiteboard: CLOSEME - 06/29

Comment 4

11 years ago
WFM with
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5

Comment 5

11 years ago
No response for five weeks, WFMs → resolving WORKSFORME.

Feel free to reopen in case it still happens with the latest Firefox and clean profile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

11 years ago
Latest versions of Firefox (2.0.0.4) have improved the behavior, and finds also text.  

But still it doesn't work fully.  It searches well, but it searches from the last valid position, even for new search text.

Steps to reproduce:

1) Open this URL: http://peccatte.karefil.com/Software/MetadataXmpSample.xml
2) Find "Jane".  It is found ok
3) Click with the mouse a few lines later
4) Find "John", it isn't found, because in step we have set the current position to a line after where the match is located.

I think that the current position shouldn't be taken into account for new searches.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
David, that's a separate bug (though probably a duplicate). Can you file a new bug report for your comment 6? The bug you filed in comment 0 here has been fixed or is at least working for you now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Updated

8 years ago
You need to log in before you can comment on or make changes to this bug.