[FIX]Forward button can load a page in the wrong frame

RESOLVED FIXED in mozilla1.9alpha1

Status

()

Core
Document Navigation
P1
normal
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: dolphinling, Assigned: bz)

Tracking

({regression})

Trunk
mozilla1.9alpha1
x86
All
regression
Points:
---
Bug Flags:
blocking1.9a1 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060727 Minefield/3.0a1 ID:2006072710 

Go to http://talkback-public.mozilla.org/reports/firefox/ . Click Firefox 2 Branch, then Simple Reports -> All Platforms (on the left). Hit back twice, then forward twice. The page loads in the wrong frame.

This happens in trunk builds starting sometime before 2006-06-21, but not in 1.8.1 builds (better regression range coming).
(Reporter)

Comment 1

12 years ago
Regressed between 2006-02-22 and 02-23
(Reporter)

Comment 2

12 years ago
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=notregexp&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-02-22&maxdate=2006-02-23+04&cvsroot=%2Fcvsroot
Bonsai link

I should have mentioned earlier, this bug was filed for timeless, who originally found it.

Also, disabling fastback does not fix the bug.
Looks like a regression from the second patch for bug 305181.  :(  I'll look into it, I guess...
Component: General → History: Session
Created attachment 231117 [details]
Subframe for testcase
So it looks like the issue is that when we go back the second time we destroy the two child docshells, which removes the corresponding SHEntries from the parent's SHEntry... which is probably wrong in this case.

bryner, any idea how we can make this consistent?  Should I just back out the additional patch for bug 305181?
Flags: blocking1.9a1+
(In reply to comment #6)
> So it looks like the issue is that when we go back the second time we destroy
> the two child docshells, which removes the corresponding SHEntries from the
> parent's SHEntry... which is probably wrong in this case.
> 
> bryner, any idea how we can make this consistent?  Should I just back out the
> additional patch for bug 305181?
> 

It's up to you, I don't really have time to analyze the session history interaction.
Created attachment 231189 [details] [diff] [review]
Backout
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #231189 - Flags: superreview?(bryner)
Attachment #231189 - Flags: review?(bryner)
Priority: -- → P1
Summary: Forward button can load a page in the wrong frame → [FIX]Forward button can load a page in the wrong frame
Target Milestone: --- → mozilla1.9alpha
Attachment #231189 - Flags: superreview?(bryner)
Attachment #231189 - Flags: superreview+
Attachment #231189 - Flags: review?(bryner)
Attachment #231189 - Flags: review+
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Flags: in-testsuite?

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: general → docshell
You need to log in before you can comment on or make changes to this bug.