Using a web reader as default reader doesn't skip the preview page to go straight to the web reader

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
13 years ago
a month ago

People

(Reporter: Waldo, Unassigned)

Tracking

Trunk
Firefox 2

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
The preview is shown because |wccr.getAutoHandler(TYPE_MAYBE_FEED)| returns null; I'm not 100% sure why yet:

http://lxr.mozilla.org/mozilla/source/browser/components/feeds/src/FeedConverter.js#197

Consequently, we fall through to the preview page code further down the method.  I'm not entirely sure what the right fix is here, but it probably involves WebContentConverter.js hacking.

This is present on both branch and trunk.
(Reporter)

Comment 1

13 years ago
This happens both with and without patches from bug 344651, FYI.
(Reporter)

Comment 2

13 years ago
Hmm, so now I'm not reproducing it -- investigating...
(Reporter)

Comment 3

13 years ago
Maybe this was just a trunk issue -- can still reproduce it there.
(Reporter)

Comment 4

13 years ago
The _init method on WebContentConverter is never being called, so the hash of autohandlers is never populated.  Somehow, it looks like the profile-after-change observer notification either isn't being received or isn't being fired.
I fixed this a while ago.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Target Milestone: Firefox 2 beta2 → Firefox 2

Updated

a month ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.