Apostrophe automatically brings up Find function no matter what the page focus is

RESOLVED DUPLICATE of bug 311376

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 311376
12 years ago
9 years ago

People

(Reporter: ralgrl630, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5

No matter if I'm in a form field OR just on the page, when I click on the apostrophe* the Find function comes up and the apostrophe is NOT rendered.  Obviously, I'm not used to clicking on the apostrophe to bring up the search function, rather I'm quite used to clicking on the apostrophe in order have that character rendered.

NOTE: the Engines search field in the toolbars area also renders this problem.  So, for example, if I were to choose an Engine (ex: Google, imdb, Amazon, etc) and I try to type something that has an apostrophe in it, the Find function appears at the bottom of the browser instead of rendering the actual character of the apostrophe, thereby making it impossible for me to conduct my search in Firefox.

Frankly, I'd consider this a show-stopper defect that should have prevented the release of the product.  This is a highly negative impact to the end-user.  As a result of this defect, I've had to use IE to perform the function I was trying to do in Firefox.  That defeats the purpose of me using Firefox (having purposely made the switch after many years of using IE to using Firefox hoping that Firefox was a better product).  Perhaps this should be considered a high-priority bug?   

* = exceptions:
in this form field and in the google groups text form field I seem to be able to depress the key for the apostrophe and not have the Find function come up.  So, what's the difference?

Reproducible: Always

Steps to Reproduce:
1. Open the browser and let any page fully render
2. Type the apostrophe key
3. Instead of the apostrophe rendering, the Find function is launched at the bottom of the browser window
4. NOTE: I have this problem whether the focus is on the page or whether the focus is within a form field (see description)
Actual Results:  
Find function is initiated

Expected Results:  
The apostrophe character is rendered

Updated

12 years ago
Whiteboard: DUPEME

Updated

12 years ago
Blocks: 320465

Comment 1

12 years ago
This happens to me all the time. When ' is keyed, the search comes up and you cannot use the ' while typing.

Comment 2

11 years ago
I also get this. It's not consistent, and appears to be linked to the copy/paste bug (i.e. both happen at once - if the apostrophe is launching find when I'm focussed on a form field, I won't be able to paste into that field either). Switching between firfox windows a few times often fixes it for me (although switching between tabs in the same window doesn't). Randomly getting focus on a few different form elements etc sometimes fixes it.

The whole thing (apostrophe, copy and paste) seems linked to some deep bug about knowing where the focus is.

Comment 3

11 years ago
I have the exact same problem, it's pretty consistent, but it depends on when and where it's used...Some web pages I have no problem using the ' just like on here, but other times, as soon as I hit it, it jumps right to the find menu...

Comment 4

11 years ago
I have also have these linked problems ... apostrophe > find and disabled Copy and Paste.  Windows XP2 fully patched and Firefox 1.5.0.6

Comment 5

11 years ago
Absolutely identical to me.

I agree wholeheartedly with the original reporter - this bug has been driving me nuts for ages now. I am close to switching back to IE now that IE7 is out - if the next couple of stable releases don't fix it I'll be gone.

Its a shame too, because I really like FF - but if its preventing me from doing my work (and I had to type that WITHOUT the damn apostrophe!) then I'll have no option. The Copy & Paste bug has teeth-clenchingly irritating, but I can just about live with it. When I dont have the ability to carry out accurate searches using Google, on the other hand...

Running XPSP2, fully patched, FF 1.5.0.6
Reporter - when this is happening are you browsing with multiple windows?  If so, do you use the firefox shortcut to open a new window or do you use ctrl+N?

Comment 7

11 years ago
I couldn't figure out when this happened for me - it seemed to be random, but following on from other comments on similar bugs it appears to be related to the copy & paste bug. 

I can confirm that it seems this only happens when you copy from one Firefox instance, then open another by clicking on the FF icon in the system tray or on the start menu and pasting into it. It doesn't seem to happen when I use Ctrl+N to open a new window, or when i use the 'new window' shortcut added to the toolbar.

Still driving me nuts though - and I'm liking IE7 but don't want to switch back unless I have to

Comment 8

11 years ago
I've had this happen on a freshly opened window (also having just logged into WinXP) on the first site I opened.  No flash, no javascript, just a textarea in a form in a frame.

I can only fix with the about:config 1/0 flip I've seen documented in bug 320465.

Apostrophe doesn't exactly strike me as an intuitive shortcut to find.  Is Ctrl-F really not enough that we had to use a character key for the same function?
(Reporter)

Comment 9

11 years ago
(In reply to comment #6)
> Reporter - when this is happening are you browsing with multiple windows?  If
> so, do you use the firefox shortcut to open a new window or do you use ctrl+N?
> 

I haven't noticed a rhyme or reason.  So that means I can't quite answer your question.  Right now I have two Firefox windows open (I don't use the tabs).  And as I type this I'm obviously able to use the apostrophe for its intended purpose.
Component: Form Manager → Find Toolbar / FastFind
QA Contact: form.manager → fast.find

Comment 10

11 years ago
(In reply to comment #8)
> Apostrophe doesn't exactly strike me as an intuitive shortcut to find.  Is
> Ctrl-F really not enough that we had to use a character key for the same
> function?
> 

Gotta agree with this wholeheartedly.

Comment 11

11 years ago
This happens to me also.
What can I do to resolve it?

*** This bug has been marked as a duplicate of 311376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.