Click on page scrolls the page to the top

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: simone.busoli, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

When I click anywhere on the page it is scrolled to the top, even if clicking on links. This happens only the first time I click. Following clicks perform the correct action (that is, clicking on links surf to the link, clicking on empty area does nothing and so on).

Reproducible: Sometimes

Steps to Reproduce:
1. Load the page
2. Scroll down
2. Click anywhere

Actual Results:  
The page scrolls to top and nothing else, even if I clicked a link.

Expected Results:  
I would expect it not to scroll.

Happens with FF 2.
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch
Does not sound like a bug, sounds like a problem with an extension or a corrupt profile.

Try in safe mode, see if it works then. If that fails then create a new profile via the profile manager and see if its reproducible then.

Comment 2

12 years ago
Do you have an example page where this happens?
(Reporter)

Comment 3

12 years ago
I'll try, I''l let you know soon. Thanks for the support, it's a very boring behavior.
(Reporter)

Comment 4

12 years ago
Tried in safe mode but this keeps happening. I cannot reproduce it always, but it happens in every page, even google search results. When I click a link it scrolls up instead of actually opening the link. What do I have to do to create a new profile? Will I loose all my settings and extensions?
(Reporter)

Comment 5

12 years ago
Looks like I had caret browsing enabled. Thanks for your support.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 6

12 years ago
(In reply to comment #5)
> Looks like I had caret browsing enabled. Thanks for your support.
> 

What's "caret browsing"? After upgrading from Firefox 1.5 to 2.0 I have this problem: When clicking on a hyperlink iside a longer frame with vertical scrollbar, the first click scrolls that frame to the beginning, but also leaved the hyperlink "selected" (= had a dotted box around). When I click it for the second time, things work as expected. Needless to say that it's very annoying to loose the current position in a long list when actually a target should be loaded in another frame.

Is that the problem you had?
(Reporter)

Comment 7

12 years ago
This is caret browsing: http://en.wikipedia.org/wiki/Caret_navigation

It is the same issue I was having, you just need to press F7 to enable or disable it.

Comment 8

12 years ago
This is exactly the behaviour that has been driving me nuts. Glad it is resolved now.

It would be nice it there was an icon in the status bar to indicate whether it is on or off. What other features does Firefox have that can be controlled by function key presses? Where are they documented?
You need to log in before you can comment on or make changes to this bug.