E-mail sort by date (or other choice) is not retained

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: H Beitman, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060729 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060729 SeaMonkey/1.5a

In the main mail window, I can no longer arrange the e-mail categories, i.e. date, subject, sender, read, etc. in the order I prefer. It defaults to subject first, then junk status, then sender, recipient, etc.  The selected categories show and can be changed, but the order in which they appear can only be changed for the current session.  As soon as the e-mail portion of Seamonkey is closed and re-opened, the order reverts to the arbitrary list above.

This problem first showed up about a week ago when I downloaded a nightly and has been in every nightly since then.



Reproducible: Always

Steps to Reproduce:
1. Open mail in Seamonkey.
2. Sort mail categories as desired (date, junk, sender, subject, recipient, size, etc.
3. Close mail and reopen.

Actual Results:  
Mail categories revert to subject, junk, sender, read, date, size, etc. regardless of previous arrangement.

Expected Results:  
Should retain sorted preference.  

This works fine in versions prior to and including 7/7/06 nightly. Nightly since about 7/25 have had this problem.

Updated

12 years ago
Keywords: regression

Comment 1

11 years ago
If you roll back to the 7/7 or earlier build, does the problem go away?  If 
not, it's possible your local storage for these settings has been corrupted.  I'm not sure, however, which file this is contained in -- panacea.dat, maybe.
(Reporter)

Comment 2

11 years ago
I can reinstall Seamonkey versions of 7/7/06 or earlier and the problem goes away, including Mozilla builds.  I can also go back and forth with two version on the computer and the older one works fine and the most recent ones do not.  I am pretty sure the issue is in the build, not in my profile.  Using the newest builds causes the sort order to reset, but it can be reset correctly with the older versions and will stay that way each time they are used.  It is almost like the new versions are automatically pressing the "Reset Column Ordering" each time they are run.

Recent builds seem to have more and more obvious issues.  In the past it usually took a while to spot a significant flaw, but nightly builds in the past few weeks have had all sorts of big issues immediately obvious.  The auto scroll feature when draging e-mails from one folder to another does not work in recent builds, and toolbars don't show up in the past few builds.  These things are obvious almost immediately upon opening the program.  I wonder if people are even trying the build before posting it?
(Reporter)

Comment 3

11 years ago
Created attachment 234244 [details]
Location of faulty Chrome directory which I replaced.

Illustration of Chrome problem location.
(Reporter)

Comment 4

11 years ago
I downloaded the nightly Windows build yesterday, 8-16-06, and the problem still showed up.  Also, the auto scroll feature (drag something beyond the window and the window moves) does not work and some of the menu headings do not show up.

I removed my profile and installed the build as if I had never used Seamonkey before on this machine, and the problem appeared to go away.  However, putting my profile back (all personalized files such as panacea.dat, prefs.js, localstore.rdf, etc. did not cause the problem to return.  Further checking revealed that the Chrome directory in the Profile directory, was different than the clean install version.  I replaced the old Chrome directory with the new one (only under profiles, not under the Seamonkey directory in programs) and the sort problem seems solved. See submitted image of directory location.

This did not fix the autoscroll problem.

Comment 5

11 years ago
=> WFM per reporter's comment 4.

The scroll-on-drag problem is bug 339474.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.