Selecting event in unifinder doesn't select/highlight event in calendar view

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: ssitter, Assigned: jminta)

Tracking

({regression})

Trunk
x86
Windows 2000
regression

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

12 years ago
Selecting event in unifinder doesn't select/highlight event in calendar view

Steps to Reproduce:
1. Create several events
2. Select events one by one in unifinder

Actual Results:
It is not visible in calendar view which event is selected.

Expected Results:
Selected event should be highlighted in calendar view too.

Additional Information:
Works in Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006072007 Calendar/0.3a2+
Fails in Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006072108 Calendar/0.3a2+
(Assignee)

Comment 1

12 years ago
Created attachment 231483 [details] [diff] [review]
add observer

selection makes me cry.  We need to add the view's observer if this is our first time showing the view.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #231483 - Flags: first-review?(mvl)

Comment 2

12 years ago
Just discussing this bug on #calendar-qa and wondering if minimonth should reflect day of selected unifinder event also (just as selecting an event in calendar view does).

Comment on attachment 231483 [details] [diff] [review]
add observer

>Index: calendar/resources/content/calendarWindow.js
>+    var view = document.getElementById(newView+"-view");
>+    if (view.displayCalendar != getCompositeCalendar()) {

Is this the only way to find out if the view has been initialized? If it is, add a comment to explain what you are doing.
(Assignee)

Comment 4

12 years ago
(In reply to comment #3)
> Is this the only way to find out if the view has been initialized? If it is,
> add a comment to explain what you are doing.
> 
Well, it was until I just checked in the initialized property of views.  However, if you review bug 321384, this patch isn't needed at all, so I'm not really inclined to update this patch
Comment on attachment 231483 [details] [diff] [review]
add observer

ok, let's obsolete this patch then
Attachment #231483 - Attachment is obsolete: true
Attachment #231483 - Flags: first-review?(mvl)

Comment 6

12 years ago
WORKSFORME since landing of bug 321384
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Updated

12 years ago
Whiteboard: [litmus testcase wanted]

Comment 7

12 years ago
Litmus testcase 2633 created
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.