bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

no overwrite option provided on attempted re-download over paused/incompleted download

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
minor
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: ciphernaut, Unassigned)

Tracking

1.8.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27, DUPEME)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060326 Firefox/1.5.0.3 (Debian-1.5.dfsg+1.5.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/2006nnnn Firefox/1.5.0.3 gentoo stable

started download of large file from sun.com. using the inbuilt download manager.
chunk of sol 10 x86 dvd iso, a zip file about 500 MB in size
required creation of user accounts, one is then provided with links which are obfuscated paths to the file.

one file was at about 90 %.  it did not seem to be downloading for quite some time. 
pausing it and resuming did not provide any results.
left it paused.

clicked the link on the download page again (I had left this window open), was prompet for the path (which I left where it was).  It then immediatly wiped the old file and startd downloading from fresh.  The old download entry in the download manager window wsa removed, the new one placed at the top of the list.

I was supprised that I wasn't presented an option to overwrite _or_ append/resume, as I would have cancelled at that point and used an external download manager to kludge download the rest (In te event the resume/append option was not provided)

Reproducible: Didn't try

Steps to Reproduce:
1.download a very large file from some site
2.have it stall at some way through
3.leave it on paused
4.click on the refereing link to download it again
5.use the same local location


Actual Results:  
watch your previously downloaded data disappear, and the file start downloading from the begining again


Expected Results:  
provided at minimum:
a dialogue providing the option to overwrite the existing file or cancel

or one step better:
provide a dialogue presenting the afformetntioned item allong with the option to wither resume the existing download, or to append data using the correct offset (for sites that support that)

gentoo using stable ebuild.

old gentoo install - 2004.1 bought up to speed recently recompiling world with deep dependancy calculations and removing all the unstable stuff.  I think I originally had firfox 1.0.3 or close to it on there
(Reporter)

Comment 1

12 years ago
directory listing after file is 'redownloaded'.  File in question is {prefix}dvd-iso-b.zip.
.nfs008d82fc00000001 is growing.

dvd-iso-e is paused.

marco@argentum[/mnt/radium/distros/sun]$ ls -la 
total 2368004
drwxr-xr-x 3 marco users      4096 2006-07-31 16:42 .
drwxr-xr-x 8 marco users      4096 2006-07-30 16:44 ..
-rw------- 1 marco users  27047631 2006-07-31 17:43 .nfs008d82fc00000001
-rw-r--r-- 1 marco users 560051445 2006-07-30 17:46 sol-10-u2-ga-x86-dvd-iso-a.zip
-rw-r--r-- 1 marco users 560681477 2006-07-31 02:42 sol-10-u2-ga-x86-dvd-iso-c.zip
-rw-r--r-- 1 marco users 560174980 2006-07-31 02:39 sol-10-u2-ga-x86-dvd-iso-d.zip
-rw------- 1 marco users  43674031 2006-07-31 16:42 sol-10-u2-ga-x86-dvd-iso-e.zip.part
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch

Updated

11 years ago
Whiteboard: CLOSEME 06/27 → CLOSEME 06/27, DUPEME
Works for me on Trunk with Fedora F7

-> Closing as works for me because of missing feedback if this is still reproducible in the latest release (Firefox 2.0.0.4) or Trunk Build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.