In read/unread (eyeglasses) view, the two groups should be sorted by date sent.

RESOLVED DUPLICATE of bug 57898

Status

MailNews Core
Backend
--
enhancement
RESOLVED DUPLICATE of bug 57898
12 years ago
2 years ago

People

(Reporter: Carl Ponder, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Thunderbird version 1.5.0.4 (20060516)

I sort my smessages by clicking on the eyeglasses icon, i.e. the read/unread view.
Besides arranging the messages into the two groups (unread on top), I want them
sorted by date within the two groups. As it is, I see no logical ordering, date
or alphabetical or lexicograohic or anything else.

I'd recommend that either (a) the messages preserve whatever order had been applied prior to clicking on the read/unread icon, or (b) use the date as the
default (ascending if unread goes on the bottom, or descending if unread goes
on the top).

I *think* I saw the order change when I added messages and also when I
compacted the folders. It still didn't make sense though.

Reproducible: Always

Steps to Reproduce:
1. Click on eyeglasses icon
2. Look at the order of the messages *not* with the green "unread" dots.


Actual Results:  
Messages are not arranged in any order.

Expected Results:  
I would have expected them to be ordered by date.

Some of the messages were from as far back as 2003. I don't know if the dates are
formatted dufferently on these older messages. Note that sorting by "date" works fine, though.

I'm going to log this as an enhancement instead of a bug, though, since it could
be argued that there is no defined behavior here to violate.

Comment 1

11 years ago
(In reply to comment #0)
> I'd recommend that either (a) the messages preserve whatever order had been
> applied prior to clicking on the read/unread icon, or (b) use the date as the
> default (ascending if unread goes on the bottom, or descending if unread goes
> on the top).

The actual secondary order for sorting is "Order Received" which is usually close to "Date" but can be very different, especially for local folders where you've copied messages (Order Received shows the order in which the messages were copied).

The RFE for user-specified multiple sort criteria is bug 57898.  Either mark this as a dupe of that, or focus this bug (by changing the summary) on your suggestion (b).
(Reporter)

Comment 2

11 years ago
Ok -- following Mike's recommendation -- I think that secondary-sorting by "sent" date would be the most useful default.
Summary: Messages are sorted uselessly when I select read/unread (eyeglasses) view → In read/unread (eyeglasses) view, the two groups should be sorted by date sent.
(Assignee)

Updated

11 years ago
Product: Core → MailNews Core

Updated

11 years ago
Assignee: mscott → nobody
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → MailNews: Backend
Ever confirmed: true
OS: Linux → All
Product: Thunderbird → Core
QA Contact: front-end → backend
Hardware: PC → All
Version: unspecified → Trunk

Comment 3

2 years ago
Secondary sorting has been implemented in bug 57898.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 57898
You need to log in before you can comment on or make changes to this bug.