JavaScript Alert Popup window message not read by default

RESOLVED INVALID

Status

()

Core
Disability Access APIs
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Wayne DeAngelo, Assigned: Aaron Leventhal)

Tracking

(Blocks: 1 bug, {access})

Trunk
x86
Windows XP
access
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

86 bytes, text/html
Details
(Reporter)

Description

11 years ago
Env: Windows XP, Bon Echo nightly build 20060731, and JAWS 7.1.

Problem: When running FF2 with the javascript alert (see attached file)the contents of the popup is not read by JAWS.

Steps to recreate:

1. Download the attached file, start JAWS and FF2.
2. Ins + down arrow till you get the the example heading of "Javascript Popup current Time"
3.Tab to the button "Display the Current Time" button.
4. JAWS announces only the title of the Popup window which is "Javascript Application" and stops there. It should read the information inside the window which is "The current time is ...."

Expected results: FF2 & JAWS should read the string within the Popup window.
(Reporter)

Comment 1

11 years ago
Created attachment 231455 [details]
testcase

Comment 2

11 years ago
*** Bug 346708 has been marked as a duplicate of this bug. ***
Does this work with WindowEyes?  If so, file a bug against JAWS.
(Assignee)

Updated

10 years ago
Assignee: nobody → aaronleventhal
Blocks: 342901
Component: Disability Access → Disability Access APIs
Product: Firefox → Core
QA Contact: disability.access → accessibility-apis
(Assignee)

Comment 4

10 years ago
Created attachment 268002 [details]
Much simpler testcase

Indeed this is only a problem with JAWS, but I will try to use describedby or some other way to get this spoken.
Attachment #231455 - Attachment is obsolete: true
(Assignee)

Comment 5

10 years ago
I'm unable to work around this. JAWS should notice that it's ROLE_ALERT and read all the static text in the dialog.

Tim, can you take this one up with Freedom Scientific using the "Much simpler testcase" file. Once there's a bug filed there you can close this one as INVALID.

Comment 6

10 years ago
I've filed it with them, but I'll keep this around until I hear from them.  
(Assignee)

Updated

10 years ago
Blocks: 368875
(Assignee)

Comment 7

10 years ago
This is working correctly in Window-Eyes but not in JAWS. Marco, can you make sure it is filed with Freedom Scientific?

Joanie, this is something to try in Orca.
(Assignee)

Comment 8

10 years ago
Not a Firefox bug.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 9

10 years ago
Aaron, confirmed that JAWS does not read the text inside the Alert. However, in looking at the window with AccExplorer, I notice that there are actually three children, the first of which is an invisible text object, the second one is the text object containing the word "hello", the third one being the OK button. What's up with this invisible first child?
(Assignee)

Comment 10

10 years ago
The invisible child is made visible when there is a different kind of alert. JAWS should just skip over invisible objects. I don't think that's the issue, but I guess I could be wrong.
You need to log in before you can comment on or make changes to this bug.