Tab bar scroller and tab focus problem

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Maxim Radugin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060731 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060731 BonEcho/2.0b1

When there are multiple tabs opened, and scroll buttons appear, closing the leftmost tab will move focus to the second tab from the left, not the first one.

Reproducible: Always

Steps to Reproduce:
1. Open 20 empty tabs (to make horizontal scroll buttons appear on the bar)
2. Move with the scroll button to the very last tab
3. Close leftmost tab on the bar (by pressing close button on the tab)

Actual Results:  
The second tab from the left will get the focus

Expected Results:  
First tab to get focus

Comment 1

12 years ago
I think this might be a dupe.  *checking*

Comment 2

12 years ago
This WFM with Bon Echo Nightly from 20060811
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.