valgrind warning reading uninitialized mIgnoreClick in nsFormFillController::MouseClick

RESOLVED WORKSFORME

Status

()

Toolkit
Form Manager
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({valgrind})

1.8 Branch
x86
Linux
valgrind
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

If I press enter to submit a form, I get a valgrind warning about uninitialized memory in nsFormFillController::MouseClick reading the mIgnoreClick variable.

Steps to reproduce:
 1. go to http://www.flickr.com/signin/flickr
 2. click in username box
 3. enter username (need not be real)
 4. hit tab
 5. enter password (need not be real)
 6. hit tab
 7. hit space
 8. hit tab
 9. hit enter to submit form

Actual results:
Valgrind warning

Expected results:
no valgrind warning

Observed in:
1.8 branch from a day or two ago, debug+opt, Linux
Created attachment 231497 [details]
valgrind warning
Flags: blocking-firefox2?
(Note that I'm not sure that submitting with the mouse doesn't cause this problem, but that's my suspicion since there's a MouseDown handler.)
Version: unspecified → 1.8 Branch
This is a one-line fix to get deterministic behavior.  The question is figuring out which behavior is right (PR_TRUE or PR_FALSE).
A quick glance says initializing to false is the right thing to do, although I'm not sure this code was designed for MouseClick to be called from keyboard events, and I'm not sure it really makes sense.
It wasn't really designed for that, you'll see that it returns early if it fails to QI to MouseEvent, it just happens to check the uninitialized mIgnoreClick first.
Flags: blocking-firefox2?
Keywords: valgrind

Updated

10 years ago
Component: Satchel → Form Manager
I think this code has since gone away... The MouseClick() method in FormFillController is just a 1-line "return PR_TRUE" now, and there's no mIgnoreMouseClick member either.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.