enable nsSigHandlers trapping for x86_64

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: sylvain.pasche, Assigned: jag-mozilla)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1b1) Gecko/20060801 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1b1) Gecko/20060801 BonEcho/2.0b1

patch coming

Reproducible: Always
(Reporter)

Comment 1

12 years ago
Created attachment 231575 [details] [diff] [review]
patch, v1

That is working fine for me. But I don't know it was not enabled for other more complex reasons.
Attachment #231575 - Flags: review?(bryner)

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

12 years ago
s/know it was/know if it was/
Attachment #231575 - Flags: review?(bryner) → review+
(Reporter)

Comment 3

12 years ago
Comment on attachment 231575 [details] [diff] [review]
patch, v1

I think I forgot to ask for super-review (I took bug 333538 as example). Can you commit that afterwards?
Attachment #231575 - Flags: superreview?(bryner)
Attachment #231575 - Flags: superreview?(bryner) → superreview+
Checked in, thanks.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
It's probably severely broken in debug+opt builds on newer gcc's -- at least it was the last time I tested.
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> It's probably severely broken in debug+opt builds on newer gcc's -- at least it
> was the last time I tested.
> 

I have been testing this with gcc 4.0. Maybe I will try with gcc 4.1.

By "severly broken", you mean that the adresses reported by the stacktrace are not correct?
I can attach some output there if helpful to diagnose the issues.
(Reporter)

Comment 7

12 years ago
Created attachment 232597 [details]
sample stack trace output on x86_64, gcc 4.1
I mean that not only are large numbers of stack frames missing, but it often crashed somewhere in the middle of the stack when EBP was used for something other than the frame pointer, especially when the stack went through system libraries which often ship without the frame pointer.
*** Bug 347287 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.