Closed Bug 346974 Opened 15 years ago Closed 15 years ago

Proxies and extension updates don't mix well

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 312473

People

(Reporter: william, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5

Updating extensions doesn't work if you have a proxy. Logging into a website first to get the proxy login is required before updating extensions. Firefox should detect this and prompt instead of displaying corrupted download message.

Reproducible: Always

Steps to Reproduce:
[The assumption is that there are out of date extensions and Firefox has previously detected this and you are using a proxy server] 

Start Firefox (1.5.0.5)
Goto Tools, Extensions menu
Press one of the "Update Now" buttons for any one of the extensions
Error message box appears:
"Firefox could not install the file at http://releases.mozilla.org/pub/ ... (URL depends on extension) ... because: Invalid file hash (possible download corruption)
Close the extensions dialog
Go to a website that prompts for the username/password for your proxy server
If this works, then repeat extension upgrade from Tools, Extensions menu, noting that this time the extension can be updated.
Therefore the problem is down to Firefox not prompting the user to log into the proxy server.

*** This bug has been marked as a duplicate of 312473 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.