Do AddressBook initialization on a background thread

RESOLVED WONTFIX

Status

Camino Graveyard
OS Integration
--
enhancement
RESOLVED WONTFIX
12 years ago
4 years ago

People

(Reporter: hophi, Unassigned)

Tracking

unspecified
Future
PowerPC
Mac OS X

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.5) Gecko/20060723 Firefox/1.5.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.5) Gecko/20060723 Firefox/1.5.0.5

I have used Camino before and it was my preferred browser but for a reason I can't decipher it has stopped working. I upgraded to latest version, tried to install it several times, after deleting (uninstalling old version) and it still hangs up on opening. 

Reproducible: Always




Analysis of sampling pid 958 every 10.000000 milliseconds
Call graph:
    274 Thread_0f0f
      274 start
        274 start
          274 NSApplicationMain
            274 -[NSApplication run]
              274 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]
                274 _DPSNextEvent
                  274 BlockUntilNextEventMatchingListInMode
                    274 ReceiveNextEventCommon
                      274 RunCurrentEventLoopInMode
                        274 CFRunLoopRunSpecific
                          274 __CFRunLoopRun
                            274 __CFRunLoopDoSources0
                              274 __CFRunLoopPerformPerform
                                274 __NSFireMainThreadPerform
                                  274 DNS_GetDomainName
                                    274 DNS_GetDomainName
                                      274 DNS_GetDomainName
                                        274 Wallet_ReleaseAllLists
                                          274 +[ABAddressBook sharedAddressBook]
                                            274 +[ABAddressBook nts_CreateSharedAddressBook]
                                              274 +[ABAddressBook nts_SharedAddressBook]
                                                274 -[ABAddressBook nts_InitDefaultContactManager]
                                                  274 -[ABAddressBook nts_OpenContactManagerWithMode:cacheSchema:]
                                                    274 nts_OpenDatabase
                                                      274 sleep
                                                        274 nanosleep
                                                          274 mach_wait_until
                                                            274 mach_wait_until
    274 Thread_1003
      274 _pthread_body
        274 PR_Select
          274 nsThread::Main(void*)
            274 nsSocketTransportService::Run()
              274 nsSocketTransportService::Poll(unsigned*)
                274 PR_OpenDir
                  274 poll
                    274 select
                      274 select
    274 Thread_1103
      274 _pthread_body
        274 PR_Select
          274 nsThread::Main(void*)
            274 TimerThread::Run()
              274 PR_WaitCondVar
                274 PR_Unlock
                  274 pthread_cond_timedwait
                    274 semaphore_timedwait_signal_trap
                      274 semaphore_timedwait_signal_trap
    274 Thread_1203
      274 _pthread_body
        274 __CFSocketManager
          274 select
            274 select

Total number in stack (recursive counted multiple, when >=5):

Sort by top of stack, same collapsed (when >= 5):
        select        548
        mach_wait_until        274
        semaphore_timedwait_signal_trap        274
Sample analysis of process 958 written to file /dev/stdout
Sampling process 958 each 10 msecs 300 times

Comment 1

12 years ago
This looks like a slightly different version of something like bug 303936.  Does Address Book also hang on launch for you?
(Reporter)

Comment 2

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
> rv:1.8.0.5) Gecko/20060723 Firefox/1.5.0.5
> Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
> rv:1.8.0.5) Gecko/20060723 Firefox/1.5.0.5
> 
> I have used Camino before and it was my preferred browser but for a reason I
> can't decipher it has stopped working. I upgraded to latest version, tried to
> install it several times, after deleting (uninstalling old version) and it
> still hangs up on opening. 
> 
> Reproducible: Always
> 
> 
> 
> 
> Analysis of sampling pid 958 every 10.000000 milliseconds
> Call graph:
>     274 Thread_0f0f
>       274 start
>         274 start
>           274 NSApplicationMain
>             274 -[NSApplication run]
>               274 -[NSApplication
> nextEventMatchingMask:untilDate:inMode:dequeue:]
>                 274 _DPSNextEvent
>                   274 BlockUntilNextEventMatchingListInMode
>                     274 ReceiveNextEventCommon
>                       274 RunCurrentEventLoopInMode
>                         274 CFRunLoopRunSpecific
>                           274 __CFRunLoopRun
>                             274 __CFRunLoopDoSources0
>                               274 __CFRunLoopPerformPerform
>                                 274 __NSFireMainThreadPerform
>                                   274 DNS_GetDomainName
>                                     274 DNS_GetDomainName
>                                       274 DNS_GetDomainName
>                                         274 Wallet_ReleaseAllLists
>                                           274 +[ABAddressBook
> sharedAddressBook]
>                                             274 +[ABAddressBook
> nts_CreateSharedAddressBook]
>                                               274 +[ABAddressBook
> nts_SharedAddressBook]
>                                                 274 -[ABAddressBook
> nts_InitDefaultContactManager]
>                                                   274 -[ABAddressBook
> nts_OpenContactManagerWithMode:cacheSchema:]
>                                                     274 nts_OpenDatabase
>                                                       274 sleep
>                                                         274 nanosleep
>                                                           274 mach_wait_until
>                                                             274 mach_wait_until
>     274 Thread_1003
>       274 _pthread_body
>         274 PR_Select
>           274 nsThread::Main(void*)
>             274 nsSocketTransportService::Run()
>               274 nsSocketTransportService::Poll(unsigned*)
>                 274 PR_OpenDir
>                   274 poll
>                     274 select
>                       274 select
>     274 Thread_1103
>       274 _pthread_body
>         274 PR_Select
>           274 nsThread::Main(void*)
>             274 TimerThread::Run()
>               274 PR_WaitCondVar
>                 274 PR_Unlock
>                   274 pthread_cond_timedwait
>                     274 semaphore_timedwait_signal_trap
>                       274 semaphore_timedwait_signal_trap
>     274 Thread_1203
>       274 _pthread_body
>         274 __CFSocketManager
>           274 select
>             274 select
> 
> Total number in stack (recursive counted multiple, when >=5):
> 
> Sort by top of stack, same collapsed (when >= 5):
>         select        548
>         mach_wait_until        274
>         semaphore_timedwait_signal_trap        274
> Sample analysis of process 958 written to file /dev/stdout
> Sampling process 958 each 10 msecs 300 times
> 

(In reply to comment #1)> This looks like a slightly different version of something like bug 303936. 
> Does Address Book also hang on launch for you?
> You got it! Address Book does the same thing

Comment 3

12 years ago
You have an underlying system problem then, I'm afraid. There's nothing Camino can do about this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> You have an underlying system problem then, I'm afraid. There's nothing Camino
> can do about this.
> Then why is it that Firefox and Safari still work properly. Does this system failure only affect Camino and Address Book. I reinstalled OS 10.4 but that didn't clear up this problem.

Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

12 years ago
The hang is inside the AddressBook framework.  Firefox isn't affected because Firefox has absolutely no integration with AddressBook.  I don't know why Safari is unaffected; they may do AB setup more lazily (you could try opening the Address Book collection in Safari's bookmark manager and see what happens).

I suppose it's not entirely true that there's nothing Camino can do; the AB setup could be made lazy, perhaps done a background thread after launch (which  might give a small performance gain for startup as well).  Re-titling and pushing to future for consideration.

However that wouldn't actually fix your system issue, and you are likely to encounter this problem with other apps.  I would recommend filing a bug with Apple, since the fundamental problem here is that your AB framework hangs indefinitely on load, which is not something that Camino can resolve.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: installed camino several times but hangs when tried to open the welcome page. → Do AddressBook initialization on a background thread
Target Milestone: --- → Future
Moving to a more suitable component.
Component: Accessibility → OS Integration
QA Contact: accessibility → os.integration
(Reporter)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

12 years ago
The problem is fixed. I copied the Address Book folder in Library/Application Support that I had using OSX10.3.9 on a different drive and everything else fell into place including Safari and Camino. Thanks for all your attempts to help

Updated

12 years ago
Status: RESOLVED → VERIFIED

Comment 8

12 years ago
Uhm, did either of you actually read comment 5? :)

cl
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.